Fork me on GitHub
#boot
<
2018-05-04
>
kuwze19:05:35

does anyone know how I might get help for this issue?: https://gist.github.com/kuwze/5f569f3767ac70363afa762960fe17a3

seancorfield19:05:15

@kuwze Looks like you're running on Java 9? You'll need to update some libraries/versions I think to get that working.

seancorfield19:05:24

Java 9 broke a lot of stuff 😞

alandipert19:05:25

@kuwze if you don't want to upgrade libs yet, you could also try BOOT_JVM_OPTIONS="--add-modules java.xml.bind" boot cljs

seancorfield19:05:59

@alandipert Is it possible that @kuwze is using an older boot-bin?

seancorfield19:05:31

I thought the basic dynapath stuff got fixed as of Boot 2.7.0, but needed the entry point app updated too?

alandipert19:05:49

i thought it was fixed also but i've seen the xml error

alandipert19:05:21

i hope to do release rituals soon, i'll investigate

kuwze20:05:55

oh I fixed it

kuwze20:05:59

sorry to bother you guys

seancorfield20:05:26

@kuwze what did you do to fix it?

kuwze20:05:21

I added [org.clojure/clojurescript "1.10.238"] before [adzerk/boot-cljs "2.1.4"] in :dependencies

kuwze20:05:37

my reply is at the bottom

seancorfield20:05:26

boot-cljs uses an older version of ClojureScript that doesn't run on Java 9 I guess. Adding that explicit dependency overrides the transitive dependency in boot-cljs (the order doesn't actually matter).

seancorfield20:05:49

Looks like boot-cljs relies on a pretty old version of ClojureScript by default https://github.com/boot-clj/boot-cljs/blob/master/build.boot#L7 -- I think it's always a good idea to specify an explicit dependency on ClojureScript in your project, so you can control which version you're using.

kuwze20:05:07

it seems to be from using boot-reload https://github.com/adzerk-oss/boot-reload

seancorfield20:05:20

Does Clojure 1.8 run on Java 9? I would change that in your boot.properties file.

seancorfield20:05:52

But, yeah, there may be all sorts of dependencies in your setup that cause problems with Java 9...

seancorfield20:05:26

You will probably need to add an explicit dependency on a recent version of dynapath too.

kuwze20:05:48

wait what should I add to boot.properties?

kuwze20:05:01

also, where should I be looking to figure out this stuff myself?

kuwze20:05:06

wait no it was obvious in boot.properties

kuwze20:05:18

but after changing it to 1.9.0 I still get the same error...

seancorfield20:05:39

Just wanted to eliminate that as a potential cause.

seancorfield20:05:10

Add this dependency in your build.boot file: [org.tcrawley/dynapath "1.0.0"]

kuwze20:05:14

the classpath conflict line is gone though

seancorfield20:05:28

That should ensure you're not picking up an older version from anywhere.

kuwze20:05:22

same error. and it didn't download anything, so I am assuming I already had that version.

seancorfield20:05:30

Sorry, I'm out of suggestions at this point... other than "use Java 8 instead?" ¯\(ツ)

kuwze20:05:46

how would I go about telling boot to use java 8?

kuwze20:05:45

I figured it out; I just had to add a more modern version of http-kit to my dependencies like this: [http-kit "2.3.0"]

alandipert21:05:56

@kuwze good to hear, out of curiousity did the BOOT_JVM_OPTIONS way fix it for you?

kuwze21:05:42

@alandipert no... the BOOT_JVM_OPTIONS didn't work. Only adding http-kit as an explicit dependency fixed it.