Fork me on GitHub
#tools-deps
<
2020-01-14
>
rschmukler16:01:27

Hey all! I'm consuming a library that seems to have packaged itself as an uberjar including all of its dependencies. I also depend on one of the libraries it uses and it looks like that it's overwriting the requires to an old version (which requires a java class that isn't packaged in the new one). Is there any way for me to force my project to use the new version instead of what it's using?

rschmukler16:01:09

I'm not super familiar with the internals of how this all works, so if the above diagnosis is complete nonsense, please excuse me!

alexmiller16:01:16

makes total sense

alexmiller16:01:30

and no, not easily

alexmiller16:01:44

you should tell that lib to stop doing that :)

alexmiller16:01:39

the effect you need is to force your lib version earlier in the classpath ordering. tools.deps mostly does not provide support for explicit ordering

alexmiller16:01:50

I possibly could come up with a hacky workaround, but it would be a hack. the real solution is the lib