Fork me on GitHub
#clara
<
2019-04-03
>
eraserhd18:04:38

can we cut a release? I think the :exists performance is blocking us right now (still running tests, tho).

defndaines20:04:10

I wanted to test the SNAPSHOT and realized I have to install an older JDK to compile the project. In particular, :javac-options ["-target" "1.6" "-source" "1.6"] is no longer supported. Does anyone know that best version to build with? (It isn’t enough to just change those to “1.8” … that brings up a ClassNotFoundException: javax.xml.bind.DatatypeConverter issue, which I think is JDK11 [LTS] and higher.)

eraserhd21:04:44

On mac, I do JAVA_HOME=$(/usr/libexec/java_home -v 1.8) lein install or what not.

eraserhd21:04:06

That just worked for me today.

eraserhd21:04:35

The target options are only about bytecode, iirc.

mikerod21:04:48

The xml thing is common in libs that haven’t upgrade some deps yet

mikerod21:04:02

Clara has some lower version deps right now, it should be changed with some better profiles I think

mikerod21:04:12

but you can work around the jdk11 things I think with just adding to the module path

mikerod21:04:56

in :jvm-opts add "--add-modules java.xml.bind"

mikerod21:04:11

can do that in your ~/.lein/profiles.clj or just alter Clara’s project

mikerod21:04:34

oh, there is already a profile for this in clara

mikerod21:04:50

lein with-profile java9 install

mikerod21:04:09

you can build with a bit higher cljs/clj too with a profile built-in

mikerod21:04:24

lein with-profile java9,recent-clj install

mikerod21:04:45

However, the java9 is slightly misleading, I think it should work with jdk11 too (pending any not testing jdk11 issues with clara or lib it uses)

mikerod21:04:00

I do not see this though :javac-options ["-target" "1.6" "-source" "1.6"] and that doesn’t seem ideal to me

mikerod21:04:18

I think Clara should remove that, maybe a good PR…

mikerod21:04:55

maybe just do this: lein update-in : assoc :javac-opts "^:replace []" -- with-profile java9, recent-clj install - hah, quite rough

wparker21:04:04

@eraserhd Regarding cutting a release in the near future, that seems reasonable to me - any objections anyone? Probably 0.19.1 looking at the changelog.

mikerod21:04:08

We likely need to make a profile to build for more modern things and make that the default dev setup. Can have separate install/deploy configuration and testing

mikerod21:04:38

@wparker release seems fine to me based on what I see

mikerod21:04:42

and minor version seems acceptable - nothing in there should be breaking or considered a “feature add”