Fork me on GitHub
#cider
<
2019-04-03
>
doglooksgood10:04:13

@bozhidar I'll open debug on error, when met the error again, I can give the trace.

alexyakushev11:04:19

Weird behavior that I've been seeing for a while and it continues: if I'm connected to multiple projects, and then I disconnect from one, the buffers that are still connected to other project lose cider-mode. I have to re-enable it in every buffer manually. Does anyone know a remedy?

qythium07:04:25

I thought this was an isolated thing on my end too! Dug a little into this by putting a trace on the cider-mode function: this seems to originate from the call to (delete-process) inside (cider--close-connection), which somehow disables cider-mode for all buffers. Not sure why/how that would happen though.

qythium15:04:52

Found the culprit: cider-disable-on-existing-clojure-buffers and cider-enable-on-existing-clojure-buffers which are run during the repl's connected and disconnect handlers

qythium15:04:35

commenting those function calls out solves the issue, I wonder why they were there in the first place?

manuel11:04:12

happens to me too

orestis11:04:59

Oh, happens to me too. I always shrugged it thought I did something wrong.

bozhidar12:04:26

That definitely sounds like a bug to me. Probably some hook triggers disabling cider-mode in all Clojure buffers.

liammccombes14:04:31

Hi - I’m having some trouble with cider-connect. My workflow is that I start my app from the command line, using lein-ring, by invoking lein ring server-headless, then use cider-connect to connect to the process. This worked in the past, but now when I run cider-connect, I get the error message

15:40:42.549 ERROR: Unhandled REPL handler exception processing message {:op describe, :session c5b63de3-8573-422a-9fc0-6c4ad08923fe, :id 3} {}
java.lang.ClassCastException: clojure.lang.Var cannot be cast to java.lang.String
along with a stacktrace. any hints on how I can go about debugging what’s wrong?

bozhidar16:04:33

What’s the stacktrace?

rob70420:04:49

Anyone use speedbar? I add symbols to a clojure file and they are not showing up in the speedbar, even when I re-eval the file.

frozenlock21:04:04

Hello! Is there something to do to enable pprint in a cljs repl?

bozhidar21:04:14

It’s enabled by default in CIDER 0.20+.

bozhidar21:04:46

It doesn’t matter what type of REPL are you using.

frozenlock21:04:49

Hmmm.. I must have messed up something 😕

frozenlock21:04:05

brb, I'll restart emacs just to be sure

frozenlock21:04:39

Still printing everything on one line 🤔

richiardiandrea21:04:44

@frozenlock just a note that I haven't seen pretty printing working in shadow-cljs

frozenlock21:04:26

I'm in figwheel-main

frozenlock21:04:38

So maybe it's cljs related