Fork me on GitHub
#boot
<
2018-08-16
>
borkdude09:08:46

I try to build a project but I get

clojure.lang.ExceptionInfo: Could not find artifact org.apache.jena:apache-jena-libs:jar:3.4.0 in clojars ()
Doesn’t boot look into maven central automatically as well?

borkdude09:08:33

hmm, this works:

boot -d org.apache.jena/apache-jena-libs repl

borkdude09:08:13

hmm, no, it fails with the same message

borkdude09:08:45

oh :extension "pom" fixed it

borkdude12:08:21

I’ve made a release of aristotle to clojars: https://clojars.org/org.clojars.borkdude/aristotle/versions/0.0.1-0-SNAPSHOT But when I try boot -d org.clojars.borkdude/aristotle:0.0.1-0-SNAPSHOT repl, I get:

Could not find artifact org.apache.jena:apache-jena-libs:jar:3.4.0 in clojars ()
so, same error.

borkdude12:08:31

Maybe I should build it differently

chokheli14:08:57

Hey guys, I’m trying to switch to boot but I’m having a tough time making it work properly.

chokheli15:08:05

when I run the following command (grabbed from http://luminusweb.net) boot -d boot/new new -t luminus -n guestbook -a +boot -a +h2 it crashes hopelessly…

chokheli15:08:11

➜  ~ boot -d boot/new new -t luminus -n guestbook -a +boot -a +h2
                              java.lang.Thread.run              Thread.java:  748
java.util.concurrent.ThreadPoolExecutor$Worker.run  ThreadPoolExecutor.java:  624
 java.util.concurrent.ThreadPoolExecutor.runWorker  ThreadPoolExecutor.java: 1149
               java.util.concurrent.FutureTask.run          FutureTask.java:  266
                                               ...
               clojure.core/binding-conveyor-fn/fn                 core.clj: 1938
                                 boot.core/boot/fn                 core.clj: 1033
                                               ...
                         boot.core/construct-tasks                 core.clj:  995
                                clojure.core/apply                 core.clj:  646
                                               ...
                                boot.new/eval45/fn                  new.clj:    9
java.lang.IllegalArgumentException: option :args must be of type [str]
        clojure.lang.ExceptionInfo: option :args must be of type [str]
    line: 3

richiardiandrea15:08:18

It might be related to a recent regression I am going to fix. I think I will have some time this weekend for that, in the meantime you could switch to previous versions with no issue I think