Fork me on GitHub
#spacemacs
<
2020-06-25
>
murtaza5215:06:16

the following blog - http://jr0cket.co.uk/2016/07/YASnippets-for-faster-clojure-development.html mentions that the ns get added when a new file is created, this used to work for me some time back, but currently does not happen, any leads on what could be the issue ?

practicalli-john16:06:52

Yes, it is clj-refactor that automatically adds the namespace when creating a new file. There is an ns snippets, so if you type ns then expand it will populate with the current namespace. Both need the REPL running to work.

practicalli-john16:06:50

This is more up to date than the blog post

murtaza5205:06:50

thanks that worked I did not know about M-/ for completions. I need to read up on the clj-refactor for spacemacs.

murtaza5216:06:34

I installed spacemacs on a new machine, and I keep getting the below error -

Starting new Ispell process /usr/bin/aspell with default dictionary...
Error enabling Flyspell mode:
(Error: No word lists can be found for the language "en_US".)
How do I configure flyspell ?

practicalli-john16:06:44

Not sure if it's flyspell error or if the binary flyspell uses, e.g aspell. I would first check aspell or similar is installed and runs on the command line, then check the path of that command and that Emacs is using the path the spelling binary is on.

murtaza5216:06:21

ok this really strange, I have a new clj project, and in that when I try to navigate the file Spc p f, it shows all files starting with ./src/.... basically add files and dirs are prepended with`./`, this is also causing the .gitignore rules to be ignored.

practicalli-john16:06:23

Did you change to the develop branch when installing Spacemacs? Just a thought.

practicalli-john16:06:48

Or maybe some packages didn't download properly. Try restarting Emacs and check the message buffer

murtaza5216:06:50

yes its on the develop branch , just checked it

murtaza5217:06:17

restarted, created the project again from a template, same problem.

murtaza5217:06:28

the problem is only with this project ..

practicalli-john17:06:24

What command is used to create the project? I assume the template used contains a .gitignore file

murtaza5217:06:17

clj -A:new dv.fulcro-template com.sevenolives/hisaab +all

practicalli-john17:06:10

I get the same as you, very strange

practicalli-john17:06:34

I tried setting it to a clojjure project with a .dir-locals.el file but id didnt make any difference. I dont have any other ideas. Maybe asking in the #emacs channel as to why projectile would add leading ./ to its output for a particular project

murtaza5217:06:56

thanks for trying it out