Fork me on GitHub
#kaocha
<
2021-04-15
>
plexus07:04:37

> ERROR in unit (core.clj:6) @marharyta.obraztsova are those three lines all the info you are getting? is there a stacktrace? does it mention a file in /tmp with more info? It's really hard to glean anything from what you've shared.

plexus07:04:11

@schmandle could you add

[lambdaisland/glogi "1.0.100"]
{lambdaisland/glogi {:mvn/version "1.0.100"}}
to your deps.edn or project.clj and see if that allows you to use the latest kaocha-cljs?

schmandle07:04:58

yes, this works:

{lambdaisland/kaocha           {:mvn/version "RELEASE"}
 lambdaisland/kaocha-cljs      {:mvn/version "RELEASE"}
 lambdaisland/glogi            {:mvn/version "1.0.100"}
 lambdaisland/kaocha-junit-xml {:mvn/version "RELEASE"}}

schmandle07:04:03

:thumbsup:

metal 2
colinkahn18:04:08

Hi, I’m having an issue where when running at the repl kaocha looses the binding for the current plugins when running the :post-summary hook. I narrowed it down to here https://github.com/lambdaisland/kaocha/blob/55d1321aec6ecb3ec21af1dd910da52c15c324f3/src/kaocha/repl.clj#L155 Wanted to get a second set of eyes before I logged an issue as I don’t see anyway for plugin/run-hook to still have plugin/*current-chain* outside of the api/run function.

Alys Brooks20:04:25

Thanks for letting us know! So you're trying to access plugin/*current-chain* from a hook? What do you need it for, in case there's an alternative to using plugin/*current-chain* ?

colinkahn21:04:13

@U01FJUDL57C I found this when using the “profiling” plugin, which uses the :post-summary hook. Currently running this with the repl api doesn’t output the profiling summary because of plugin/*current-chain* no longer being bound outside the api/run call.