Fork me on GitHub
#boot
<
2016-09-01
>
alandipert02:09:01

@kenny nice!

benedek18:09:02

hi gals/guys, working on fixing this: https://github.com/clojure-emacs/cider/issues/1824 wondering if you can help me out. the fix seems to be to add an exclusion to tools.nrepl so it will look like this: [org.clojure/tools.nrepl "0.2.12” :exclusions [org.clojure/clojure]]. Cider already uses the -d option to add depedendecies from the command line. Is there support to provide exclusions as well from the CLI?

micha20:09:03

@benedek this is an option in 2.7.0

micha20:09:14

-E --exclusions SYM         Add the SYM dependency to the set of global exclusions.

micha20:09:24

but exclusions is probably not the ideal solution

micha20:09:45

you probably want to add a direct dependency on the version you want

micha20:09:38

like you should always have a org.clojure/clojure dependency, imho

benedek20:09:21

you mean in cider?

micha20:09:56

in your project

micha20:09:08

like whenever you use boot really

benedek20:09:41

yeah but this is what to do when injecting cider deps for a cider repl

benedek20:09:28

I guess the project is the user's businesses so to say...

benedek20:09:41

2.7.0 is the next major release, right?

benedek20:09:02

#472 on github. thx for the info!

micha20:09:05

yep next release, coming soon 🙂

micha20:09:38

master is in a good working state, if you can try it out we'd greatly appreciate it 🙂

benedek20:09:07

will give it a spin