Fork me on GitHub
#babashka
<
2020-07-13
>
mmz07:07:41

@orestis @borkdude started writing a blogpost about it yesterday. Hope to finish it this week.

coolj13:07:28

We use the babashka jar to run scripts in Jenkins. The Jenkins we use runs on Java 8. bb v0.0.97 is the last release that supports Java 8 as bb moved to Java 11 in v0.0.98. You’ll see something like

Exception in thread "main" java.lang.UnsupportedClassVersionError: sci/impl/Reflector has been compiled by a more recent version of the Java Runtime (class file version 55.0), this version of the Java Runtime only recognizes class file versions up to 52.0
It’s not an issue for me but just said I’d mention it in case someone else hits it.

borkdude13:07:07

Any reason you’re not running the binary bb?

coolj13:07:31

I couldn’t install the binary but I could run java - it’s an odd corporate edge case for sure.

borkdude15:07:22

Docker is another possibility