Fork me on GitHub
#clojure-belgium
<
2016-06-02
>
r00z07:06:58

Hello guys, could someone please update a description of meetup event? Looks like Edu has busy time now 🙂

r00z07:06:03

Here is a desciption: Bitcoin and Blockchain are quite popular topics nowadays. There is a lot of hype and investment around these technologies. There are not a lot of libraries and frameworks that could be used in Clojure for experiments and projects related to a Blockchain. But due to a nature of a Blockchain, as a sort of immutable database of transactions, - Clojure could be a perfect match for it. Plan of a talk: 1) I'll give short introduction to a blockchain and bitcoin. 2) I'll tell about my experiments with Freecoin - Complementary currency toolkit in clojure https://github.com/d-cent/freecoin 3) Demo Many thanks to Kunstmaan for hosting this event! Igor Ruzanov, Software developer

r00z08:06:06

thanks, Ray!

stijn10:06:00

@raymcdermott: for your report https://github.com/yogthos/clojure-error-message-catalog/issues/22, setting :pedantic? :abort in leiningen helps identifying conflicting dependency resolutions

raymcdermott10:06:07

@stijn: oh, I didn’t know about that I will check - thanks

raymcdermott11:06:27

@stijn: funnily enough I was complaining that the tools should be able to help with this, after all they know when there is a conflict … and I was right but didn’t know how right, which is nearly useless!

stijn11:06:11

it's the first thing I do when creating a new project: updating that setting 🙂

raymcdermott11:06:36

just ran it and, yes it would have saved a few clumps of hair!

raymcdermott11:06:58

is there a lein template where it is non by default?

raymcdermott11:06:30

anyway, yes - awesome tip!

stijn11:06:10

I don't know, I'm not that much into lein templates

raymcdermott11:06:15

only slight issue is that it recommended dropping the later version but actually it was necessary to drop the earlier version

raymcdermott11:06:26

but that’s not a biggie

stijn11:06:32

yes, I don't know why it does that

stijn11:06:50

anyway, there's a risk in both dropping the older or newer version

raymcdermott11:06:16

indeed - definitely one that has to be tried out

raymcdermott11:06:27

I updated the issue BTW

raymcdermott12:06:18

I had a look at the lein FAQ and it seems to pick the version closest to the root

raymcdermott12:06:15

Which seems to be a more subtle heuristic than ‘latest’ which seems more obvious - maybe the proximity heuristic has a higher success rate in the general case.