Fork me on GitHub

Hi - I have spotted some odd behaviour and don't know how to get to the bottom of it, any ideas? Here is what I see: with Emacs 26.2 and CIDER 1.0.0 if I do nrepl-toggle-message-logging to enable logging then evaluate something at the repl I get nothing back but see "Symbol’s function definition is void: seq-contains-p" in the minibuffer. If I toggle message again (turning off) everything works ok. I also have Emacs 27.1 (which might be the problem), if I use Emacs 27.1 I don't see this behaviour. I have deleted the .elc files for seq-2.22 and recompiled using my Emacs 26.2, so I don't think it's a bytecode issue. I guess the obvious answer is "use 27.1, don't use 26.2" but I am curious to get to the bottom of this - any ideas?


i would delete all elc files in your elpa directory and run emacs 26.2 and see what happens. i suspect it will work. i would then delete all elc files in your elpa directory and see what happens in 27. i suspect it will work. My off the cuff guess is that there's some incompatible bytecode between these two


by "all elc files" you mean everything under .emacs.d/elpa? i.e. get rid of all of it from all packages?


yes. if the suspected cause is invalid byte code a proper test would be removing all bytecode


ok, thanks, will give that a go


and i wonder if its "compiled" under 26 if you'll have forward compatibility but you run into issues running 27 bytecode in 26


but maybe this isn't the problem anyways so who knows


@dpsutton tried deleting all the .elc files but still seeing the same thing.


delete them all again and delete seq (is that built in now?). let seq get resolved and downloaded and see what you get? dunno after that. should be supported in emacs 26.2 as far as i am aware


the .elc files were re-generated - does that mean my emacs is interpreting the .el files, or the .elc are in somewhere other than my .emacs.d directory? In any case, I will delete seq and see how it goes


emacs will create them to speed things up.


seq-2.20 is built-in, cider 1.0.0 requires 2.22


@dpsutton thanks for the advice - I don't think there is anything else to do bar a clean install of everything. Given the problem doesn't come up with emacs 27.1 I don't think I am going to pursue this much further. It only cropped up as a side note on a bigger issue, but that's for another day I think. Thanks again. Alasdair.


sounds good. sorry i couldn't help more