Fork me on GitHub
Jared Kristensen07:11:25

Hey everyone! I tried to view the code of conduct but didn't have access. Wanted to see if it's ok to post Clojure jobs in this channel/slack group?


We (moderators) assume members are able to find appropriate channels via the Slack UI but that often doesn't appear to be the case šŸ˜

Jared Kristensen00:11:59

Thanks for linking @seancorfield. Just a heads up the code of conduct linked in this channel is and is not public and cannot be viewed šŸ™‚


Oh, I wonder when that stopped being a public document? Sorry. I'll mention it to the admin team.


there are some job specific channels just for that. #jobs #remote-jobs should help in getting the highest concentration of people looking for jobs


and clojure jobs are always welcome, I'm sure

hipster coder20:11:54

I know a lot of Clojurians use Vim/SpaceMacsā€¦ has anyone hit the problem where they cannot override their OSX /usr/bin/vim with the newest Vim 8.2 versionā€¦ using homebrew? It looks like homebrew removed the override command, instead of deprecating it ?

hipster coder20:11:57

basically, someone on the brew team royally screwed this up, by removing a much needed flag command


But homebrew is installing binaries into /usr/local/bin

hipster coder21:11:24

@delaguardo yes, I worked around itā€¦ by adding the /usr/local/bin path into my bashrcā€¦ homebrew was supposed to take care of updating the system default exe but they removed the command flag to do that.

hipster coder21:11:20

I am irritated. Who knows. Maybe it was a huge security hackā€¦ over riding the system defaultā€¦ but it cost me an Sunday, hunting this down. I am ready to dump homebrew and just compile everything like I do on Linux.

hipster coder21:11:26

when I first started out coding, as a childā€¦ I did not have to spend half my week reading stackoverflows and githubs, tracking down broken bugs and broken toolsā€¦ things just worked. I could spend 90% of my time coding.


I think itā€™s uncharitable to call this a royal screwup. Even compiling everything manually on Linux the default would be to make install into /usr/local. This or /opt has been the expected behaviour of non OS managed packages on unix platforms for many, many years. /usr/local/bin is also higher precedence by default than /usr/bin on almost any sane unix, including, I thought, all current macOS installs out of the box.


@nathantech2005 Heh, I use linuxbrew to manage everything on Ubuntu šŸ™‚

hipster coder21:11:50

yea, I am researchingā€¦ why OSX will not allow me to change /usr/bin/vim


it was introduced in El Capitan as System Integrity Protection

hipster coder03:12:43

ahh ok. thank you so much for that updateā€¦

hipster coder21:11:59

even with root


I think it is pretty standard practice for Linux/OSX users to carefully manage their command path env variables, to be in the order they wish.


And I thought that when I used homebrew on both Linux and OSX that it updated my bashrc for me, but it has been long enough that I don't truly recall now.

hipster coder21:11:02

yesā€¦ and Linux allows me to setup my bins how I wantā€¦ OSX is not allowing meā€¦ some kind of over ride wheel permissions things

hipster coder21:11:21

nope. I had to add a path inside bashrcā€¦ just 1 little line


@nathantech2005 I'm not sure but I think macOS kinda assumes that those directories are managed by the OS and aren't written to so it can safely updates these during upgrades. Also, there is:

$ cat /etc/paths
which contains the paths that are included in your shell by default probably

hipster coder21:11:38

because thereā€™s 2 versions of vim on my system, now


You can use sudo on OSX if you really want to, but recent OSX versions are doing more security measures to lock down the standard binary directories than older versions did.

hipster coder21:11:13

yea, I understandā€¦ OSX has put some kind of idiot-proof feature into itā€¦ I get it

hipster coder21:11:24

nope, sudo is not working

hipster coder21:11:38

it might be a Catalina thing

hipster coder21:11:51

I just upgraded to Catalina


I just checked PATH on my old Mac and /usr/local/bin is part of the core path, ahead of /usr/bin -- I didn't have to do anything to set that up that way. But that's 10.12.

hipster coder21:11:21

anyways, really apppreciate the feedback


I have a ~/Dropbox/bin folder where I put binaries I like, and they come with me every system I work on

hipster coder21:11:00

@seancorfield interestingā€¦. yes. thatā€™s the fix

hipster coder21:11:26

you can just swap out your bins when needed?


Interesting bit from that SO answer:

Note that while /usr/local/bin doesn't exist by default, it is in the default PATH, so as soon as you create it, it'll be searched for commands.

hipster coder21:11:58

yes, thatā€™s what I had to doā€¦ on Catalinaā€¦ was add /usr/local/bin to the path

hipster coder21:11:11

export PATH=ā€œ/usr/local/bin:$PATHā€

hipster coder21:11:33

added that line to my .bashrc

hipster coder21:11:45

because homebrew put the exe into the path


the default shell is zsh now on macos

hipster coder21:11:31

ahh really, I did not know, they moved to zsh

hipster coder21:11:36

zsh is actually really good


I'm still on bash because I stayed on 10.12 I guess?

hipster coder21:11:44

yea, I was afraid to upgrade to Catalinaā€¦ but it went smooth

hipster coder21:11:58

in the past, upgrades, with Apple, have bricked my devices


I won't upgrade because almost every macOS upgrade breaks my dev env setup šŸ˜ When I replace this 8 year old iMac, I'm going to Windows šŸ™‚

hipster coder21:11:06

and I mean, only 2 versions later, bricked

hipster coder21:11:31

upgrades bricked my mobile devices..

hipster coder21:11:36

but the desktop upgrade went really well

hipster coder21:11:54

8 years? yea, not going to work

hipster coder21:11:59

I would not even try that


(after many iPhones over the years, I finally switched to Android this year -- happy with that)

hipster coder21:11:18

this is going off on a tangentā€¦


It started on a tangent šŸ™‚

šŸ˜‚ 3
hipster coder21:11:29

but after many years, I finally found how to fix my usb-c on apple

hipster coder22:11:06

@seancorfield best laugh all weekend, thanks


I don't know if I would prefer Android over Apple, if your Google account gets disabled you might be locked out of certain app accounts. Nasty.

hipster coder22:11:30

disabled google account?

hipster coder22:11:01

woahā€¦ better have a few accounts, I guess

hipster coder22:11:10

I have gotten locked out of MFAā€¦

hipster coder22:11:19

where MFA backup codes did not work

hipster coder22:11:00

well, anyways, time for a breakā€¦ thank you muchā€¦ great thoughtsā€¦ at least itā€™s fixed