Fork me on GitHub
#boot
<
2016-11-07
>
lxsameer08:11:18

@micha hi, it seems that using pretty print cause stackoverflow ? do you confirm it ?

lxsameer11:11:11

any one know about this? ^

micha14:11:06

@lxsameer which version of boot are you using?

micha14:11:47

@nxqd are you using the speak or notify tasks?

micha14:11:15

those are the only parts of boot that would attempt to do anything with audio

nxqd14:11:30

@micha I'm not sure, there is no speak or notify in build.boot file. I'm new to boot btw

micha14:11:51

@nxqd the build task includes speak via composition

nxqd14:11:10

oh, thanks

micha14:11:16

you should be able to just comment that out

nxqd14:11:48

thanks for helping, I just had the word notify in my head xD

micha14:11:06

if you can figure out a test we can perform to check for audio support we could include that in the task

micha14:11:25

i guess a try/catch would be sufficient

nxqd14:11:39

yeah that would be great too, a try catch would do in this case

micha14:11:43

if you create a github issue i will make the fix for next release

micha14:11:22

thanks! :+1:

shen17:11:13

Hi. Appreciate it if someone could check I’m not barking up the wrong tree, but I’m struggling to mix UTF-8 JS and boot-http.

pandeiro17:11:34

@shen You might need to specify the encoding in your script tag?

shen17:11:46

hey. I did

pandeiro17:11:54

I remember having this issue with d3

shen17:11:03

It’s a plotly issue

shen17:11:22

Check out my reproduction of the issue?

pandeiro17:11:50

I can't right now but I will... Are you using jetty or httpkit?

shen17:11:15

Um… I’m running "boot -d pandeiro/boot-http serve -d . wait"

shen17:11:19

what would that be?

pandeiro17:11:27

That uses jetty by default

pandeiro17:11:39

Try with -k flag?

pandeiro17:11:01

Then we could see if it's a jetty specific cfg issue

shen17:11:39

where should the -k flag go?

lxsameer17:11:43

@micha: I'm using boot 2.6

pandeiro17:11:28

Anywhere in the command after serve

shen17:11:26

Ok. That works

shen17:11:10

So, jetty issue?

shen17:11:44

What should I change in my build.boot to use httpkit instead?

pandeiro17:11:46

Yeah, probably doesn't serve as utf by default

pandeiro17:11:15

:httpkit true in the serve line

pandeiro17:11:44

But that would be a nice default to set I imagine, as long as user could override

shen17:11:06

to serve utf?

pandeiro17:11:25

Yeah by default, I think that's sane

shen17:11:06

Cool. Trying that workaround on my actual project now… Thanks a lot though

pandeiro17:11:45

I don't even know how/where to set it, this is where Java leaks into our wonderful lisp lives

shen17:11:52

Ok. That works for the full thing too. Really appreciate the help! Will have a look wrt to jetty and utf. See if there’s anything useful I can find.

pandeiro17:11:39

Awesome, glad to provide the work around ;)

danielsz19:11:19

Yay! It's @micha and @alandipert on the cognicast (again)! Great conversation! I'd listen to you guys every week!

richiardiandrea19:11:56

number 3 2! still cool stuff 😉