Fork me on GitHub
#cider
<
2016-03-12
>
otfrom10:03:41

ooh, I love it when the bugs are reproducable...

otfrom11:03:26

just putting this here in case anyone sees my problem from last night

otfrom11:03:31

;; good cider
(use-package cider
  :ensure t
  :defer t
  :config
  (setq cider-repl-history-file (concat user-emacs-directory "cider-history")
        cider-repl-history-size 1000
	cider-font-lock-dynamically '(macro core function var)
        cider-overlays-use-font-lock t
        cider-pprint-fn 'fipp
        cider-cljs-lein-repl "(do (use 'figwheel-sidecar.repl-api) (start-figwheel!) (cljs-repl))"))

otfrom11:03:33

;; bad cider config
;; (add-hook 'cider-mode-hook #'cider-enlighten-mode) causes problems
;; on cider-restart or other 2nd cider session
(use-package cider
  :ensure t
  :defer t
  :config
  (setq cider-repl-history-file (concat user-emacs-directory "cider-history")
        cider-repl-history-size 1000
	cider-font-lock-dynamically '(macro core function var)
        cider-overlays-use-font-lock t
        cider-pprint-fn 'fipp
        cider-cljs-lein-repl "(do (use 'figwheel-sidecar.repl-api) (start-figwheel!) (cljs-repl))")
  (add-hook 'cider-mode-hook #'cider-enlighten-mode))

otfrom11:03:43

I don't know/think it is a bug though

malabarba13:03:40

Looks like it is. Could you file an issue please?

malabarba13:03:45

@hans well that's weird. Do you use enlighten-mode? Are those functions traced?

hans13:03:07

@malabarba no/no. The strange thing is that not only function names are highlighted, but also the slash in double quotes.

malabarba13:03:52

Yeah. That looks like something in your configuration

malabarba13:03:06

But I don't know. Could be a bit

malabarba13:03:29

Can you reproduce it reliably?

hans14:03:55

I will try in a bit, thanks

hans15:03:38

occurs when i compile a file

hans15:03:55

well, the decoration is present on all compiled files.

malabarba18:03:43

@hans could you start Emacs with emacs -Q, then do package-initialize, and then try to reproduce your issue?

hans19:03:06

@malabarba: will do

hans19:03:37

@malabarba: no change, although package-initialize did not do anything visible.

hans19:03:57

i've killed my ~/.emacs.d/elpa directory and reinstalled everything, still the same. would this be a cider configuration problem?