Fork me on GitHub
#boot
<
2017-01-02
>
danielsz19:01:02

I'm using Dirac and boot-cljs-devtools. It has worked great for me, but in one of my projects, the moment I type in the console (DevTools) I get 404 errors such as this: Could not load content for : HTTP status code: 404

danielsz19:01:13

Anyone else has seen this?

danielsz19:01:56

The main.out fragment doesn't seem correct to me.

danielsz19:01:46

I think it should just be out, no?

danielsz19:01:18

And the path is wrong, too.

richiardiandrea19:01:48

@danielsz the main.out part is correct if you don't have any cljs.edn file in place

richiardiandrea19:01:58

but yes the path is wrong

richiardiandrea19:01:24

it looks like it is appending the asset-path twice for some reason, and it might be a boot-reload issue

danielsz19:01:39

Hmm... I do have a cljs.edn file though.

richiardiandrea19:01:48

can you paste the content?

danielsz19:01:15

Sure, it's just a require {:require [teamsocial.core]}

richiardiandrea19:01:00

uhm, oh what about the options to boot-reload?

richiardiandrea19:01:53

and to boot-cljs-devtools (btw we have split the tasks in the new -SNAPSHOT)

danielsz19:01:58

Yes, I'm using the new snapshot.

danielsz19:01:28

I don't have options to boot-reload, should I set something there?

danielsz19:01:19

What baffles me is that I have the same setup for another project, and no error there.

danielsz19:01:16

I don't give options to the tasks in boot-cljs-devtools neither.

danielsz19:01:34

It's just the defaults, I guess.

richiardiandrea19:01:09

uhm...very weird indeed

richiardiandrea19:01:36

can you share the project by any chance?

danielsz19:01:16

Yes, I can invite you to the bitbucket repo. Do you have a username?

richiardiandrea19:01:32

yep -> arichiardi

danielsz19:01:39

Yeah, I'm curious what you make out of it.

richiardiandrea19:01:48

I am launching it

richiardiandrea19:01:51

(downloading a bunch of stuff :))

danielsz19:01:04

yeah, I bet

richiardiandrea19:01:47

@danielsz where is the error coming from? I can't see anything in the console 😉

danielsz19:01:25

ah, OK, so did you open localhost:3025

danielsz19:01:47

OK, and did you connect to the Dirac DevTools.

richiardiandrea19:01:19

let me try to evaluate

danielsz19:01:34

yes, that's when the errors come (for me at least) 🙂

richiardiandrea19:01:31

oh yes I see them now

richiardiandrea19:01:05

you know, it seems like a dirac error to me 😉

richiardiandrea19:01:44

and it says to report it on dirac/issues

danielsz19:01:19

OK, well @darwin is online, so I can see what he says.

richiardiandrea19:01:32

I agree there is something going on there

danielsz19:01:32

So can we rule out boot-cljs-devtools?

richiardiandrea19:01:13

do you have the same problem with the old version?

danielsz19:01:36

I haven't tried it with an older version. But like I said I have another project with exactly the same setup (as far as I can see), and no errors. Which boggles the mind.

richiardiandrea19:01:06

Mine too, I am trying the old version

richiardiandrea20:01:27

@danielsz even more boggling now: clojure.lang.ExceptionInfo: Could not find artifact

danielsz20:01:15

Just by going back to the previous boot-cljs-devtools?

richiardiandrea20:01:30

I actually don't see it in clojars...unless I am using the wrong name ?

richiardiandrea20:01:52

@danielsz sorry I don't know what happened my bad 😉

danielsz20:01:36

Sounds like a core java library. Did it fix itself?

richiardiandrea20:01:30

same errors with boot-cljs-devtools 0.1.2

danielsz20:01:47

Ah. Well, in the meantime @darwin went offline, but I'll ping him tomorrow.

danielsz20:01:01

Thank you so much for helping out.

richiardiandrea20:01:49

Ah ah didn't do anything! The cljs options are ok it seems (`boot -v dev`)

richiardiandrea20:01:44

ok the verdict is to ask dirac I don't see anything weird on the boot side of things

danielsz20:01:22

Sure, will do. I'll keep you updated. Thanks again!

bcbradley23:01:56

i'm playing around in the repl with webpages using slurp, but found clj-tagsoup easier to wield

bcbradley23:01:07

how do i dynamically require clj-tagsoup at the repl