Fork me on GitHub
Steven Deobald03:05:12

Updated the Quickstart with System Requirements, as suggested by @seancorfield: If anyone else runs into difficulties with the simple setup, please let us know and we'll update the list.


“Clojure 1.10.3”?


Any particular reason for the .3 as opposed to 1.10(.0) there?

Steven Deobald20:05:58

Hmm. Nope. I just grabbed the exact dependency from the Crux project.clj. It's been enough years I don't think I remember how Maven transitive deps work (if I ever did). Will any 1.10.x satisfy if Crux itself depends on 1.10.3?


I meant more "Is there a reason Crux requires 1.10.3 specifically as opposed to earlier versions of 1.10?" -- if you're talking about "minimum" versions.

Steven Deobald20:05:28

This is a question for @U899JBRPF or @U050V1N74 I'm afraid. All will be revealed on Tuesday. 😉


At this point, I can't imagine anyone still using 1.10.0 -- because of the slow startup bug that got fixed in 1.10.1 -- but I think a lot of people are still on 1.10.1...


I guess it's reasonable to ask: will Crux run on 1.9? (I suspect the answer would be "no" at this point)

Steven Deobald16:05:31

True, I'm not aware of change between 1.10.1 and 1.10.3 that Crux depends on... but I am not aware of many things. 😉 The version bump was clearly intentional (and global to the codebase), so I can only assume there was some requirement for it:


1.9 - not right now, we use requiring-resolve 1.10.1 - no reason it shouldn't, have run a couple of our main tests against it and looks fine.


we don't have a lot of dependencies - I tend to keep an eye out for releases to our core ones and bump the others every so often


(and thank you for updating the doc!)