Fork me on GitHub
#untangled
<
2016-03-16
>
tony.kay15:03:52

@currentoor: Totally game, just not anywhere on our radar. Untangled is us sharing what we use with the community, and we have no need for boot here. So, if you want to contribute something that adds that support, we'd welcome it assuming it doesn't break anything we use.

folcon15:03:58

@tony.kay: hey, just trying to go through . A few questions: Is this supposed to work with intellij? I’m currently getting:

ANALYSIS ERROR: No such namespace: doo.runner, could not locate doo/runner.cljs, doo/runner.cljc, or Closure namespace "doo.runner" in file test/client/app/all_tests.cljs on file null, line null, column null

tony.kay15:03:43

It is. That is what we use. Doo is the test runner for CI...let me glance at why that might be going sideways

folcon15:03:12

Is this a replacement for ?

tony.kay15:03:19

Do you have anything in your lein profile (e.g. .lein)

tony.kay15:03:05

not a replacement. Untangled does all of the Om plumbing for you, so everything about Om UI, queries, and such still applies. You just don't have to write all of the parser or networking stuff.

folcon15:03:44

ah, I was working though it until and had to stop :)… thanks for that btw!

tony.kay15:03:07

welcome. I stopped there mainly because we were developing this...which makes a lot of that unneeded

folcon15:03:39

{:user {:plugins [[lein-cljfmt "0.1.10"]
                  [lein-try "0.4.3"]
                  [lein-difftest "2.0.0"]
                  [lein-marginalia "0.8.0" :exclusions [org.clojure/clojure]]
                  [lein-pprint "1.1.2"]
                  [lein-swank "1.4.5"]
                  [lein-catnip "0.5.1" :exclusions [org.clojure/clojure]]
                  [lein-kibit "0.0.8" :exclusions [org.clojure/clojure org.clojure/tool$
                  [lein-environ "1.0.0"]
                  [lein-cljsbuild "1.0.5"]
                  [lein-autoexpect "1.4.2"]
                  [lein-ancient "0.6.5" :exclusions [org.clojure/clojure cheshire]]]
        :env {:twitter-consumer-key “<>"
              :twitter-consumer-secret “<>"
              :twitter-token “<>"
              :twitter-secret “<>"}}}

tony.kay15:03:43

Ah....all of those cause dependencies to get injected into the build. You might try disabling that (move it out of the way) and completely clean/reimport the project.

tony.kay15:03:02

The cljsbuild 1.0.5 is almost certainly a bad idea

folcon15:03:43

I’m just trying it now

tony.kay15:03:13

k. I'm about to record a video, so I'll be offline in a few.

folcon15:03:55

ok, it seems the -Dtest build barfs, I haven’t checked all the combinations, but -Dtutorial by itself seems fine. As does -Dclient -server.

tony.kay15:03:42

Ah, I don't have the test build configured in my env...perhaps it is broken

tony.kay15:03:48

thanks for the note

tony.kay15:03:03

hm, nope...if I add -Dtest, works fine.

folcon15:03:58

ok, I don’t think that it’s due to my user plugin’s as I’ve commented them all out for the moment

tony.kay15:03:04

I do see that we did not fully implement the CI stuff on this project yet, though

tony.kay15:03:22

so the all-tests namespace is referring to doo, but isn't being used

folcon15:03:43

I’ll do some more on the tutorial and bring up things as I see them?

tony.kay15:03:56

sure, appreciate it

tony.kay15:03:22

it is more documentation than anything at the moment. Not had time to add much in the way of exercises

tony.kay15:03:43

I'd recommend playing with untangled-todomvc while reading the docs in tutorial

tony.kay15:03:03

it is a full-stack working app, and if you've played with Om it will get you going quickly

folcon15:03:26

oh, just remembered, your docs here say: to browse to . But the url doesn’t appear to exist if I use. JVM_OPTS="-Dtutorial" lein run -m clojure.main script/figwheel.clj.

tony.kay15:03:49

try it with index instead (no filename)

tony.kay15:03:32

fixed in repo

folcon15:03:39

yep, that does work, just pointing out a doc issue simple_smile...

folcon15:03:29

just to check when you said -Dtest works, are you trying JVM_OPTS="-Dtest" lein run -m clojure.main script/figwheel.clj at the command line?

tony.kay15:03:43

I'm in IntelliJ

tony.kay15:03:51

adding to the JVM args of a run config

folcon15:03:58

ok, let me try that

folcon15:03:43

I get that stack trace in intellij

tony.kay15:03:26

No reader function for tag object in file

tony.kay15:03:46

sounds sorta like you're getting old versions of tools in the classpath somehow, is my guess

tony.kay15:03:42

IntelliJ can be notorious for caching things. I sometimes have to clean things out (e.g. git clean -xfd) and re-import the project. I'm touching up the project file to do automated tests...that might change things too

tony.kay15:03:14

you might also try (from CL) lein deps :tree and see if you see conflicts/warnings about deps

tony.kay15:03:25

be suspicious of cljs build tools/namespace things, etc

tony.kay16:03:01

Also, try it from the CL. I just added a Makefile, so make dev should start all three builds. If it works there, then it is a cursive bug.

tony.kay16:03:15

but cleaning/reimport usually solves that for me

folcon16:03:41

ok, well I’m recreating the project

folcon16:03:52

and I’ll pull in the changes

tony.kay16:03:05

yeah, pull before re-import

tony.kay16:03:24

I updated project file, and you want IJ to see that during import

folcon16:03:44

ok, so I’ve pulled and then reimported. When running make dev I still get an error on the client part:

JVM_OPTS="-server -Dclient -Dtest -Dtutorial" rlwrap lein run -m clojure.main ./script/figwheel.clj
STARTING FIGWHEEL ON BUILDS:  (client test tutorial)
Figwheel: Starting server at 
Figwheel: Watching build - test
Compiling "resources/public/js/specs.js" from ["src/client" "src/shared" "test/client" "test/shared"]...
Successfully compiled "resources/public/js/specs.js" in 4.017 seconds.
Figwheel: Watching build - client
Compiling "resources/public/js/main.js" from ["dev/client" "src/client" "src/shared"]...
{:tag :cljs/analysis-error}
ANALYSIS ERROR: No reader function for tag object in file src/client/app/ui.cljs on file null, line null, column null
Successfully compiled "resources/public/js/main.js" in 1.253 seconds.
Figwheel: Watching build - tutorial
Compiling "resources/public/js/tutorial.js" from ["src/tutorial" "src/shared"]...
Successfully compiled "resources/public/js/tutorial.js" in 2.547 seconds.
Figwheel: Starting CSS Watcher for paths  ["resources/public/css"]
Launching ClojureScript REPL for build: tutorial

tony.kay16:03:27

sorry...no more clues on my end 😞

tony.kay16:03:43

UI is such a simple file on that project

tony.kay16:03:05

lein deps :tree is still my next step

tony.kay16:03:08

make sure you aren't getting deps injecting from elsewhere like profiles

tony.kay16:03:44

@folcon: Tutorial or TodoMVC? I just realized I might be on wrong project

tony.kay16:03:44

cause I'm seeing what you were seeing, but on todomvc for some reason

tony.kay16:03:47

actually, a full clean seems to have cleared it up

adambros16:03:43

as a note, the query editors in untangled_tutorial.D_Queries dont seem to be working when i click Run Query, can you confirm that?

tony.kay16:03:03

I was seeing that in older version...thought I had fixed it

tony.kay16:03:09

make sure you've pulled

tony.kay16:03:31

hm. The query editor was a contribution, and the rendering wasn't written correctly. A fix t oOm broke it

tony.kay16:03:54

I worked on that the other day and thought I pushed the fix

tony.kay16:03:16

but I'm rather fragmented these days...double-check me simple_smile

tony.kay16:03:59

@folcon: Looks like I do have some kind of deps thing that causes periodic issues like you are seeing. I just got it, but not consistently 😞

tony.kay16:03:04

OK, the doo CI test running is to blame.

tony.kay16:03:12

for compile problems....exploring

tony.kay16:03:25

Yeah, doo is pulling in a diff version of tools reader that is hosing cljs build

tony.kay17:03:56

@folcon: I think I fixed it. Let me know if that latest project file works for you

folcon17:03:16

@tony.kay: oh, sorry if I wasn’t clear, I’m on tutorial.

folcon17:03:22

give me a minute

tony.kay17:03:39

it was clear...I just saw the problem you were having on todo, but not on tutorial. I think I fixed both

tony.kay17:03:58

some kind of tools namespace dependency resolution problem getting the wrong version and confusing everything....bleh

folcon17:03:47

yep it seems to be gone now simple_smile...

folcon17:03:25

thanks simple_smile...

folcon17:03:47

right, I’ll start working though the tutorial and note if I find issues.

tony.kay17:03:26

great, appreciate it

folcon18:03:53

@tony.kay: I may be being dense, but as far as I can tell you mention the Untangled support viewer in untangled_tutorial.B_UI for the first time. But it’s not linked to anything or explained further. So I’m left wondering what it is.

tony.kay18:03:22

Ah, I don't think it is in the tutorial yet, but it is live in todomvc

tony.kay18:03:43

It allows you to send a VCR-style recording of the user interactions with the UI to your server, for debugging client issues

tony.kay18:03:01

The intro video I'm working on will show that

folcon18:03:14

that’s nice :)… Also like the writing style so far, friendly and conversational

tony.kay18:03:26

hm...looking like it might have been the parallel build feature

tony.kay18:03:40

had that turned on. lots of things seem to be clearing up turning it off

tony.kay18:03:01

argh...then again...

tony.kay23:03:12

Whew...just finished an intro video. 3.5 minutes and it took me practically all day. Promotion sure is time consuming simple_smile

tony.kay23:03:35

Should be up on the web in the next hour...I hope