Fork me on GitHub
#tools-deps
<
2018-11-28
>
eval202010:11:57

@dominicm tools-deps equivalent of lein-try - very nice! 👌:skin-tone-2:

borkdude12:11:37

what does user/find-deps do?

eval202014:11:07

Published something similar (ie rebel-readline + deps) earlier this year. The above inspired me to actually document it: https://gitlab.com/eval/deps-try/tree/master#deps-try

dominicm16:11:08

What's the :repl/try about?

borkdude20:11:42

Is there a way to get -R test + -C test + also the possibility to override -m? With -A:test I cannot do this.

eval202020:11:47

@dominicm it’s a hook from rebel that kickstarts the loading of the libs (calling (unreleased) tools-deps’ add-lib). (Must be an easier way to start a repl where you want some commands to be executed before taking input)

dominicm21:11:46

There is, edge does it

dominicm21:11:21

Rebel takes the same flags as clojure main

kenny22:11:51

Is there a way to get rid of the logback.xml file that aws-maven brings in via tools-deps?

dominicm22:11:14

@kenny I solved it by making a fork and opening a jira.

dominicm22:11:08

https://github.com/SevereOverfl0w/tools.deps.alpha/tree/add-lib?files=1 I based it on the add-lib branch. I can live without s3 wagon support.

kenny22:11:54

Unfortunately I need S3 support because Datomic Cloud stores its artifacts there 😞

alexmiller22:11:02

I am interested in fixing that for you, after conj (although there may be new ways to do so)

dominicm06:11:57

That's great, thanks!

dpsutton22:11:39

would make a fun unsession to fix a bug with alex miller

alexmiller22:11:09

Oh yeah so fun ;)

😂 8
dpsutton22:11:35

"work during the conference. thanks" lol

mattyulrich22:11:18

Hi all. I'm having an issue that looks like transitive dependency problems with a corporate repo. I have the repo listed in :mvn/repos - but it looks like transitive deps from java libraries that I reference from that repo are not resolving. When trying to resolve the deps, it seems to be looking at clojars instead. Is this a known issue or something that should be working?

hiredman22:11:51

you might checkout the poms of those transitive deps to see if they do anything kind of odd like relocations https://dev.clojure.org/jira/browse/TDEPS-8

hiredman22:11:22

there are a lot of issues in the tools.deps jira, so in order to discern you are experiencing a known issue or not, you may have to narrow it down

amar23:11:33

Hi everyone. Has anyone been able to use a private git library as a dependency in a CI environment like Google Cloud Build? The key is there and if I use git from the command line, the repo can be successfully cloned. I'm seeing

com.jcraft.jsch.agentproxy.AgentProxyException: connector is not available:
 	at com.jcraft.jsch.agentproxy.ConnectorFactory.createConnector(ConnectorFactory.java:120)
 	at clojure.tools.gitlibs.impl$fn__843.invokeStatic(impl.clj:30)
 	at clojure.tools.gitlibs.impl$fn__843.invoke(impl.clj:28)
 	at clojure.lang.Delay.deref(Delay.java:42)

dominicm06:11:51

You need to start an ssh agent, and add the key to it

amar21:11:53

Great. Thanks!