Fork me on GitHub
#spacemacs
<
2019-11-04
>
euccastro00:11:58

thanks to both!

kirill.salykin10:11:08

Hi all, after latest update of spacemacs (develop branch) I see this error: Error in dotspacemacs/user-config: Symbol's value as variable is void: counsel-find-file-map Any ideas whats wrong and how i can fix it?

kirill.salykin11:11:26

Seems not related to initialization time There is no Backtrace buffer

practicalli-john15:11:23

SPC f e D to update your .spacemacs file ?? Maybe something has been added, changed.

practicalli-john15:11:09

Or perhaps take a copy of .spacemacs and delete the contents of dotspacemacs/user-config. Perhaps something you added there is conflicting.

kirill.salykin15:11:58

I think it is because I’ve excluded counsil and friends (via excluded packages)

kirill.salykin15:11:07

and this commit broke it

kirill.salykin16:11:13

do you think it is bad idea to explicitly exclude counsil?

practicalli-john18:11:38

If you are using Ivy, then Counsel seems to be important to the Spacemacs setup (not tried Ivy in depth myself though)

practicalli-john18:11:02

Is there a reason to exclude counsel and other packages? If you are not using them then they wont be loaded. If you are not using a layer that doesnt use (need) them, then removing that layer would be more appropriate.

practicalli-john18:11:44

I am afraid I dont know why you excluded packages, so am only guessing.

kirill.salykin06:11:41

I am not using Ivy, honestly saying I dont remember why I excluded them You are right, there is no need to exlclude them Thanks for advices!

kirill.salykin06:11:43

I’ll start later with fresh new .spacemacs file, thanks for the idea as well

kirill.salykin09:11:12

Ok, the error caused by lispyville-set-key-theme but it is strange, because lispyville doesnt use counsil