Fork me on GitHub
#shadow-cljs
<
2018-11-22
>
manuel06:11:15

hi. shadow-cljs has been reporting this on my build:

------ WARNING #1 --------------------------------------------------------------
 File: bidi/bidi.cljc:29:12
--------------------------------------------------------------------------------
  26 | actually a valid UUID (this is handled by the route matching logic)."
  27 |   [s]
  28 |   #?(:clj (java.util.UUID/fromString s)
  29 |      :cljs (cljs.core.UUID. s)))
------------------^-------------------------------------------------------------
 Wrong number of args (1) passed to cljs.core.UUID
--------------------------------------------------------------------------------
  30 | 
  31 | ;; When forming paths, parameters are encoded into the URI according to
  32 | ;; the parameter value type.
  33 | 
--------------------------------------------------------------------------------
It's a warning, so nothing serious as I can keep working with no problem. Just wondering: should I report it to bidi?

thheller08:11:55

probably yes

thheller08:11:20

they are supposed to use (cljs.core/uuid s)

thheller08:11:34

or just (uuid s)

manuel08:11:50

ok, I'll open an issue on their repo.

manuel08:11:24

nevermind, there is already an issue on this: https://github.com/juxt/bidi/issues/189

lsnape14:11:07

Hi thheller, FYI I've got asset fingerprinting working in a configure build hook similar to how we outlined it last week. Deploying today. If it all works then I'll run the implementation past you.

👍 1
lsnape14:11:19

I think there's still quite a bit of work required before it's ready for a PR into shadow-cljs.

mattly22:11:26

shadow-cljs just started reporting this on a project I hadn't touched for a few weeks:

thheller22:11:20

@mattly shadow 2.7.x requires CLJS 1.10.439

thheller22:11:28

so need to bump that when using deps.edn

mattly22:11:15

huh thanks

mattly22:11:23

I don't remember upgrading anything

thheller22:11:43

you probably have a version range in your package.json for shadow-cljs

thheller22:11:08

"shadow-cljs":"^2.6.12" or whatever

mattly22:11:20

yeah indeed

thheller22:11:24

that automatically upgrades

thheller22:11:38

can just set a fixed version (which I recommend doing)

thheller22:11:53

to avoid issues such as this 😉

mattly22:11:09

yeah that's typically what I do

thheller22:11:11

no idea why version ranges are still the default in node world 😞

👍 1
mattly22:11:58

perhaps because they think anything older than a day is obsolete