This page is not created by, affiliated with, or supported by Slack Technologies, Inc.
2020-04-15
Channels
- # announcements (3)
- # architecture (1)
- # babashka (52)
- # beginners (228)
- # calva (1)
- # chlorine-clover (31)
- # cider (9)
- # clj-kondo (16)
- # cljs-dev (25)
- # cljsrn (21)
- # clojure (116)
- # clojure-argentina (8)
- # clojure-europe (18)
- # clojure-france (17)
- # clojure-germany (1)
- # clojure-nl (5)
- # clojure-spec (49)
- # clojure-uk (63)
- # clojurescript (59)
- # community-development (14)
- # conjure (89)
- # core-matrix (1)
- # cursive (18)
- # data-science (1)
- # datomic (27)
- # exercism (4)
- # figwheel-main (5)
- # fulcro (38)
- # ghostwheel (8)
- # graalvm (5)
- # hoplon (2)
- # jobs-discuss (17)
- # juxt (1)
- # lambdaisland (5)
- # luminus (1)
- # lumo (9)
- # malli (7)
- # off-topic (32)
- # planck (24)
- # re-frame (14)
- # reagent (14)
- # reitit (14)
- # rum (23)
- # shadow-cljs (80)
- # spacemacs (2)
- # sql (6)
- # unrepl (1)
- # xtdb (2)
Release candidate with a bunch of fixes and new stuff https://github.com/tonsky/rum/blob/gh-pages/CHANGELOG.md#0115-snapshot
Give it a try on your projects and report any issues in the repo
0.11.5-SNAPSHOT
> Maybe Warning: Text content did not match. no, same warnings in release version, so no difference.
@serioga I should ask Nikita to push a release to Clojars, but git deps is easier for me, since it doesn't require anything. Is there a way to test things locally for you?
yeah that's fine
@serioga 0.11.5-SNAPSHOT
@roman01la why react 16.8.6-0
? I use 16.13.0-0
without problem.
and sablono 0.8.6
...
we are gonna move gradually
@roman01la should I try snapshot with recent libs as well?
Ideally you'd use 16.8.6-0
, but any other newer version should be fine I think
I see warnings
Warning: componentWillMount has been renamed, and is not recommended for use. See for details.
* Move code with side effects to componentDidMount, and set initial state in the constructor.
* Rename componentWillMount to UNSAFE_componentWillMount to suppress this warning in non-strict mode. In React 17.x, only the UNSAFE_ name will work. To rename all deprecated lifecycles to their new names, you can run `npx react-codemod rename-unsafe-lifecycles` in your project source folder.
Please update the following components: player-search react-dom.inc.js:82:32
Warning: componentWillReceiveProps has been renamed, and is not recommended for use. See for details.
* Move data fetching code or side effects to componentDidUpdate.
* If you're updating state whenever props change, refactor your code to use memoization techniques or move it to static getDerivedStateFromProps. Learn more at:
* Rename componentWillReceiveProps to UNSAFE_componentWillReceiveProps to suppress this warning in non-strict mode. In React 17.x, only the UNSAFE_ name will work. To rename all deprecated lifecycles to their new names, you can run `npx react-codemod rename-unsafe-lifecycles` in your project source folder.
Please update the following components: player-search, wrapped-input
is it solvable?is that on 16.13.0-0
?
yeah, those are deprecations
not a problem for now
no, not now
Is that related to JVM SSR?