Fork me on GitHub

Yeah, I’ve noticed the same thing when working on making the job-handler a function. It really is a logical consequence. I’m trying a version where the job-handler is a function in production at work this week, and I’m going to try your suggestions for making retry-strategy a function and removing the job-type, too. It’s not a lot work - rewriting the documentation is what takes time! 🙂


I have this commit running in production at work now: I’ll look into making retry-strategy a function too. I’ll cut a new release after that change (if it sticks).


> I suggest that there’s naming updates to move that into some kind of flavour. I’m not sure I get what you mean here? :face_with_raised_eyebrow:


@msolli Apparently my basic literacy skills degraded there 😄 I was trying to indicate that job/handle! and job/retry-handler be moved into some other namespace perhaps, if you wanted to retain backwards compat. Not sure if that's a goal or not for you 🙂.


Hehe, I see. 🙂 While we’re in alpha backwards compatibility is a non-goal. The migration path should be straight-forward, even if it is a breaking change.