Fork me on GitHub

Okay, hear me out: $CLJ crypto tokens

🙅 2
Martynas M08:11:50

You have to stake $CLJ and $CLJS to get $CLJC


I heard some people are minting $CLJD

Martynas M08:11:42

I also heard that if you have regulatory problems when using these you can use Babashka and Sci. Exchanges claim that they are pegged to $CLJ at 1:1 ratio.


With $BORK used as a collateral


A bit more serious, I wonder what the uses for community token would be..

Martynas M08:11:43

There are people who managed to sell their "time" in ICO-like formats. But it was during the great hype.


that's just contract work with extra steps...

Vishwas Pawar13:11:00

My name is Vishwas. I had started a weekly newsletter called Console. Console is a free weekly round-up of open-source projects. It’s all about free, useful, innovative software, and the developers that are dedicating their precious time to creating and maintaining it. Please subscribe and also let me know how can we improve it.

Ben Sless13:11:56

Posting the same promotional message in multiple channels can be considered bad form 🙂

Ben Sless13:11:56

The news channel or this one is probably enough


Hi, is there anyone who has developed a web application in Crystal? Maybe with the help of first glance Crystal seems like a nice combination of Ruby, Lisp and ?Ocaml?. I’d be interested in a comparison with Clojure, at least in feel. Personally, I don’t have enough time to do anything serious in Crystal, unfortunately. Is there anyone here who has tried a “full-stack” Crystal and wasn’t impressed? The same question could be applied to NIM, but it seems to me that Crystal is a bit closer to the web.


Since today my (zsh) shell started displaying the path at the right side of the screen in green. Does anyone know how I can turn this off? I'm using iTerm2 and oh-my-zsh but I haven't updated oh-my-zsh for years.

Thanh Nguyen15:11:46

I am not familiar with iTerm2 myself, so I can only suggest you to try changing your ZSH theme within oh-my-zsh and see how it goes. I guess your $PS1 (variable for shell prompt) is messed up, so have a look at it as well.

Jon Boone15:11:11

It’s definitely a zsh theme — looks like you might be using either PowerLevel9K or so?

Jon Boone15:11:36

Do you have POWERLEVEL9K_RIGHT_PROMPT_ELEMENTS defined in your env?


nope, but also, I reverted the change by uninstalling nix

Jon Boone16:11:25

Ok — whatever theme you are using probably has a env variable defining the PROMPT format — and that configuration probably includes nix_shell….


$ echo $PROMPT
%(!.%{$fg_bold[red]%}.%{$fg_bold[green]%}%[email protected])%m %{$fg_bold[blue]%}%(!.%1~.%~) $(git_prompt_info)%_$(prompt_char)%{$reset_color%}

Jon Boone16:11:32

are you not using any theme at all? if you are, the $PROMPT variable in question would be theme specific….


I'm using gentoo theme


but I haven't updated ohmyzsh for ages


now I did. RPROMPT is still good (empty)

Jon Boone16:11:42

Interesting — so with the updated ohmyzsh, you don’t get the nix_shell info when you install nix?


I haven't yet installed nix again. I will try when I do


zsh sometimes goes bananas on an abrupt quit or shutdown, not sure if related


I know this is a recent change since in other tabs I had already open for a few days in iTerm2, it doesn't do this! The only thing I changed today was that I installed nix and I can't image that nix would randomly change my shell appearance...


What's nix?


@U04V15CAJ You can see where the RPROMPT is getting set by: 1. Adding set -x; exec 2>zsh-rprompt-debug.log at the very start of your .zshrc 2. Starting a new zsh process 3. Grepping that zsh-rprompt-debug.log file for RPROMPT Of course, don't forget to remove that line from .zshrc after you're done. :)


Here's what the relevant line in the log looks like in the case of my setup:

+/home/p-himik/config/zsh/themes/p-himik.zsh-theme:79> RPROMPT='%* %D{%F} !%!%{%f%k%b%}'


Thanks! I uninstalled nix and now the prompt is fixed again.. after rebooting. Still not completely sure if it was related but it seems so.




That is bizarre.


anyway, thank for this debugging stuff, that's really useful

👍 1

So @U04V15CAJ Is that the end of your nix adventure? Or did you end up reinstalling it and fixing your prompt? I’m not the ‘innovator’ type but I can be the ‘early adoptor’ sometimes, so I’m wondering if I should try nix…


I will try it next time I think I need it


can't recommend it because I don't have significant experience with it

👍 1
Colin P. Hill16:11:56

Anyone have a Slack theme handy for the Clojure colors?

Pagoda 5B21:11:52

late to the party 😁 #5881D8,#FFF8D4,#90B4FE,#FFFFFF,#91DC47,#FFFFFF,#91DC47,#63B132,#63B132,#FFFFFF


I can’t remember how long ago I found this or where I found it but I do remember it being advertised as a Clojure theme at the time! #4165A2,#1A3A73,#63B132,#FFFFFF,#1A3A73,#D1D2D3,#91DC47,#EB4D5C,#1A3A73,#D1D2D3

thanks3 4
🙂 1
👍 1

Here's another one (that I've been using for years): #FFFFFF,#90B4FE,#E4EAF7,#4C5770,#C4C4C4,#272727,#91DC47,#63B132,#90B4FE,#272727

thanks3 1
🙂 1

What are people's personal thoughts on evaluating the security risk of browser extensions? The above theme conversation reminds me of this because I've been wanting a "dark mode everywhere" chrome extension for a bit, but then these kinds of extensions need access to all data on all sites visited and I just can't justify that. I guess you can sometimes verify that they safe with some effort. A lot of these are from random people and have like 10-100 reviews. One of these days I have to start making my own quick one off personal extensions

Martynas M17:11:39

I use noscript. No, I didn't read the source.

Martynas M17:11:15

Also dark mode everywhere doesn't work because some sites track using websockets. Also it's easy to miss these when trying out extensions that have various whitelists.


The dark mode one is just for making sites have a dark appearance and isn't concerned with tracking


I just found this one which has a firefox option and seems fairly legit


I have been using DarkReader for quite a while now and it works great.

Martynas M08:11:54

I tried darkreader for a day and it makes webpages really slow. The initial load is slow. I have other extensions that run some JS too. So it's not good.


looks like we can add France to the list of organizations using Clojure/Script 🙂