Fork me on GitHub
#off-topic
<
2019-04-14
>
Ivan Koz16:04:50

https://tenor.com/view/lol-sloth-happy-dead-inside-relaxed-gif-4564941 that's literally me applying hammock driven development techniques

😂 1
parens 1
rich 2
hipster coder18:04:04

I am reading Clojure for Brave and True. But my kindle is blurring the code fonts… anyone know a simple fix for this? The text works fine except for the code sections. It’s happening on all books.

Zachary18:04:17

you could always substitute the blurry bits for the online version of the book

hipster coder18:04:52

I think I need to buy a new kindle. It’s about 10 years old. I love the paper mode style of it.

Eccentric J18:04:02

Plus the online version of the book has some errors fixed.

hipster coder18:04:29

ok, I will try reading the code from my phone. I didn’t think of that. Cool.

hipster coder18:04:59

I put all my books on my kindle. 80+ and got rid of my books. But now I am regretting it. I was trying to be minimalistic 🙂

Eccentric J18:04:36

When the kindle first happened I felt the same way. Then I realized there’s still value in physical books, so I use a combination depending on accessibility and subject matter.

Eccentric J18:04:36

Also, if you’ll forgive a shameless plug but I put together a small library tool one can use to take notes when learning Clojure from books and create interactive, well documented examples to make it easier to revisit. https://github.com/eccentric-j/book-report

1
Nico18:04:50

I would get a kobo rather than a kindle personally if you're looking for a new ebook reader.

hipster coder18:04:39

@UHZ9UUT7H is better than a kindle?

hipster coder18:04:14

Kobo is Japanese? I love things built from Japan.

Nico18:04:18

kobo are mainly better from the software side, they're a lot more open than the kindle. (support for books from any store without needing jailbreaking, doesn't rely on amazon for stuff etc)

Nico18:04:25

hardware is about equal on both imo

Eccentric J18:04:12

The kindle has gotten better about supporting other sources, most ebooks I download I can send to the kindle.

hipster coder18:04:58

It’s just weird because the display works fine on my kindle. But not the italic or code fonts. It seems more like a software error.

Nico18:04:04

that's the original kobo but they've made a lot since then. And it is japanese made although a canadian company originally. I also love how easy the kobos are to mod (mine runs koreader) compared to kindle but I'm a bit of a customisation addict and that appeals to me

Nico18:04:35

the only issue I had with brave and true on my kobo was line numbers in the code blocks displaying slightly weirdly but that is down to epub and not the book or kobo itself

Nico18:04:48

I don't have too much experience of kindle beyond ~2015 though so they have probably changed a lot since then, I've just stayed a kobo faithful because they've always worked best for me

Eccentric J18:04:53

@UGQJZ4QNR perhaps try the kindle desktop app? If it displays weird there too then it’s probably the ePub file itself. If it works then it may be a device issue.

hipster coder19:04:37

ahhh ok. Maybe I can try re-downloading the epub. Maybe the data has degenerated.

borkdude18:04:37

I’m trying to generate the sources for OpenJDK (https://github.com/openjdk/jdk) but I’m getting this error:

configure: Potential Boot JDK found at /Library/Java/JavaVirtualMachines/jdk-11.0.2.jdk/Contents/Home is incorrect JDK version (java version "11.0.2" 2019-01-15 LTS); ignoring
I’m doing this on Mac. This is when I execute bash configure.

hipster coder18:04:18

are you running the

bash configure
inside the specific Java directory?

hipster coder18:04:03

what version do you get when you type java -version in your top level dir?

hipster coder18:04:56

my first thought is… it’s confused about which java open jdk version to use? bash doesn’t know. It’s searching your paths for Java.

hipster coder18:04:41

check your JAVA_HOME env var

borkdude19:04:12

export JAVA_HOME=~/Downloads/jdk-12.jdk/Contents/Home did the trick. I think it didn’t understand my --with-boot-jdk option

hipster coder19:04:35

ya, you needed to change JAVA_HOME?

hipster coder19:04:43

OSX gets confused about paths very easily

hipster coder19:04:48

I could try to get you to switch to Linux. Less path problems. hahahaha j/k

borkdude19:04:01

more driver problems 😉

hipster coder19:04:04

I use Linux and OSX, both are great

hipster coder19:04:16

ya, you are correct. Nvidia is a challenge on Linux.

Lennart Buit19:04:31

there is jenv, works like rvm but for java versions

👍 1
Lennart Buit19:04:45

not sure if that helps

borkdude19:04:09

I’ll check it out, thanks

gklijs21:04:44

I'll just have some entries in my .bash_profile like alias jg="export JAVA_HOME='/Users/bla/Workspace/graalvm-ee-1.0.0-rc9/Contents/Home'; java -version" on my mac

hipster coder00:04:37

have you encountered any issues with readline when running Clojure? on OSX

hipster coder00:04:38

my Clojure version is looking for readline version 7 but I have version 8 installed. I am trying to get brew to install both versions. I suspect that my Ruby install which also uses readline, changed the versions on me.

Lennart Buit04:04:19

I symlinked 7 to 8 and now it works again

Lennart Buit04:04:45

I had to for I believe psql

jumar10:04:45

@borkdude if I understand, you're trying to build OpenJDK - have you read https://github.com/AdoptOpenJDK/openjdk-jdk12u/blob/master/doc/building.md#boot-jdk-requirements ? I don't remember the details but it could help to use older JDK as the "book jdk" (maybe as old as Java 8 - but definitely not 12 if you are trying to build 11)

borkdude10:04:20

It worked when I set JAVA_HOME to JDK 12. But not with the --with-boot-jdk option

jumar10:04:23

as regards to switching between different java versions I second the jenv tool recommendation - handling JAVA_HOME on Mac OS is such a mess 😞

borkdude10:04:49

so for now it’s solved

borkdude10:04:01

thanks for recommending jenv, I’ll def look at it

👍 1
borkdude18:04:48

Not sure how to fix this

borkdude18:04:50

JDK 12 didn’t work either

borkdude18:04:49

The only step I need from this build process is gen-src for java.base, because I’m missing some java.nio .java files

hipster coder18:04:41

@borkdude do you already have several Java versions on your machine?

borkdude18:04:57

yeah, a bunch, ranging from 1.7-1.11

hipster coder18:04:53

I think you need to set the default java version

hipster coder18:04:09

it looks like it’s confused about which java version is the default on osx

hipster coder18:04:38

let’s thread the discussion…

clslcl21:04:20

Any opinions on Clojure WebApp vs. Desktop? I'm preparing to write an app with lots of a visualisation (charts, canvases, etc.), so I'm thinking whether I should go for a lib like cljfx, or use that one lib that compiles clojurescript to electron, but on the other hand browservm clojurescript seems like less of a hassle with all these js libs (I think performance would be pretty much comparable in both jvm native and browser implementations)

Eccentric J22:04:21

Personally I would go the webapp route given that the libraries for visualizations are in wide use, well documented, and likely well maintained.

john23:04:10

I wonder if building a front end in js with the jvm's js rather than electron would make sense. I didn't enjoy electron's server/client setup last I checked it.

john23:04:49

Like, would a whole react app work in a webview in javafx?

clslcl00:04:24

@U050PJ2EU Eh, rn I don’t think you can cross write for javafx and the browser at all - last time I checked the libs they all had incompatible APIs, only conceptually similar in a re-framy way. You can’t have shared libraries or components, alas; so you’d have to choose between javafx and js.

john00:04:35

Hmm, okay

bherrmann11:04:02

Vega/Vega-lite seem the way to graphs these days, and they are easiest to reach from cljs... https://github.com/metasoarous/oz

Mno22:04:11

Speaking of visualizations, anybody have any recommendations of a library for creating a tree diagrams on web? (I tried d3 but honestly didn’t find it that helpful)

🌴 1
hipster coder14:04:58

how about html5 canvas?

Mno14:04:26

That was my backup plan, but if I could find something premade with interactivity in mind that would’ve saved me some thinking (I don’t personally enjoy the frontend part and will gladly throw libraries at the problem 😅) that would be nice.