Clojurians
#lumo
<
2018-06-26
>

This page is not created by, affiliated with, or supported by Slack Technologies, Inc.

seancorfield00:06:45

Not sure if this is a Lumo issue but I'm not sure where to start with this... TravisCI builds of HoneySQL are failing with

/home/travis/.nvm/versions/node/v8.11.3/lib/node_modules/lumo-cljs/bin/lumo: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by /home/travis/.nvm/versions/node/v8.11.3/lib/node_modules/lumo-cljs/bin/lumo)

richiardiandrea01:06:07

However probably Travis bumped node

richiardiandrea01:06:58

I actually don't know why I am installing nvm there actually

richiardiandrea01:06:33

Will take a look tomorrow, should be an easy fix, afk now

seancorfield23:06:45

@richiardiandrea Just FYI, I updated all the HoneySQL dependencies (in project.clj) and that made no difference to the GLIBCXX error on Travis...

richiardiandrea23:06:13

@seancorfield cool did not have time but bear with me :wink:

seancorfield00:06:28

@richiardiandrea https://travis-ci.org/jkk/honeysql/builds/397133758 -- I added the ppa:ubuntu-toolchain-r/test and then updated and installed libstdc++6... kinda brute force, but it works :slightly_smiling_face:

richiardiandrea00:06:51

uhm, yeah I will open a PR cleaning the mess up :slightly_smiling_face:

richiardiandrea00:06:09

it is probably due to the weird thing I am doing there with nvm

richiardiandrea00:06:12

sorry about that!!

seancorfield01:06:17

According to the Travis docs, nvm should already be installed. So, is this a matter of using nvm to install an earlier version of npm? Or is it Lumo itself that needs to have an older version installed?

seancorfield01:06:15

All the research I did on the error suggested that the only two solutions are: 1. rebuild you app on the host system (so it uses the older libstdc++) 2. upgrade the host (so it has the new libstdc++)

richiardiandrea02:06:32

Lumo includes node so it is just expecting the right libstd to be in the system - in the previous lumo version we were ok - lumo 1.9.0 needs a higher version - I guess if we do npm install [email protected] we settle it once and for all

richiardiandrea02:06:00

And probably we can get rid of the nvm line altogether