Clojurians
#lumo
<
2018-05-21
>

This page is not created by, affiliated with, or supported by Slack Technologies, Inc.

johanatan22:05:51

@anmonteiro do you know anything about this error?

/codebuild/output/tmp/versions/node/v9.11.1/lib/node_modules/lumo-cljs/bin/lumo: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by /codebuild/output/tmp/versions/node/v9.11.1/lib/node_modules/lumo-cljs/bin/lumo)

johanatan22:05:21

is lumo missing a dependency? or do I need to install that version of GLIBC via some other means?

anmonteiro22:05:22

@johanatan which dist/ version of linux does that machine run

johanatan22:05:01

aws/codebuild/java:openjdk-9
I'll try to find out what that is

johanatan22:05:10

i think Ubuntu 13

anmonteiro22:05:17

yeah… that sounds right

johanatan22:05:30

actually 14.04

anmonteiro22:05:15

can you upgrade to a later version of ubuntu?

johanatan22:05:39

14.04 is pretty late yea?

anmonteiro22:05:51

or just install libstdc++6

anmonteiro22:05:00

14.04 means April 2014

johanatan22:05:22

how to install libstdc++6 ? via apt-get?

hlolli22:05:00

I thought it wasn't possible to install linux in the first place without libstdc++.so.6

anmonteiro22:05:43

@johanatan yes, apt-get install -y libstdc++6

hlolli22:05:13

what's your output johnatan when you do echo $LD_LIBRARY_PATH

johanatan22:05:04

@hlolli just a sec. not a live environment so i have to wait for runs to complete. trying that SO suggestion first

hlolli22:05:31

readelf -d lumo                           ~/.npm-global/lib/node_modules/lumo-cljs/bin

Dynamic section at offset 0x3914dc0 contains 30 entries:
  Tag        Type                         Name/Value
 0x0000000000000001 (NEEDED)             Shared library: [libdl.so.2]
 0x0000000000000001 (NEEDED)             Shared library: [librt.so.1]
 0x0000000000000001 (NEEDED)             Shared library: [libstdc++.so.6]
 0x0000000000000001 (NEEDED)             Shared library: [libm.so.6]
 0x0000000000000001 (NEEDED)             Shared library: [libgcc_s.so.1]
 0x0000000000000001 (NEEDED)             Shared library: [libpthread.so.0]
 0x0000000000000001 (NEEDED)             Shared library: [libc.so.6]
looks pretty dynamically linked. So I wonder why your linker searched in /usr/lib/x86_64-linux-gnu ... curious to know and learn :slightly_smiling_face:

hlolli22:05:12

same elf signature in node for me, so I wonder if node runs for you.

johanatan22:05:01

yea, node runs fine

hlolli23:05:27

there's some difference there actually between node 9.8.0 and latest lumo on npm

readelf -sW lumo | grep GLIBCXX_3.4.20    ~/.npm-global/lib/node_modules/lumo-cljs/bin
     7: 0000000000000000     0 FUNC    GLOBAL DEFAULT  UND [email protected]_3.4.20 (5)
 17298: 0000000000000000     0 FUNC    GLOBAL DEFAULT  UND [email protected]@GLIBCXX_3.4.20

readelf -sW ./node | grep GLIBCXX_3.4.20 ~/.nvm/versions/node/v9.8.0/bin
$
could be totally unrelated, was struggling recently to patchelf the lumo binary for nixos, I believe it's a stripped binary. I say with grain of salt only after some hours of research on complex topic.

hlolli23:05:17

could be that your libstc++ version is just old

GCC 4.9.0: GLIBCXX_3.4.20, CXXABI_1.3.8
release date:
2014-04-22 07:11

hlolli23:05:44

maybe we can rethink about statically linking lumo. I wasn't able to load dynamically linked native node modules on runtime with statically linked lumo, it just crashed. Maybe since then it has been fixed, or we can find a workaround on that.

benzap23:05:39

Any plans for packaging lumo-cljs for raspberry pi via npm in the future?