Clojurians
#lumo
<
2018-01-19
>

This page is not created by, affiliated with, or supported by Slack Technologies, Inc.

dehli01:01:51

anyone here used b/node-inputs with lumo?

richiardiandrea02:01:06

@dehli uhm I am not familiar with that, where is it showing?

dehli02:01:55

I’m trying to figure out how to bundle npm dependencies into the generated js file

richiardiandrea02:01:19

@dehli so I have never tried that but being an alpha in Cljs, I would say expect many more bumps in lumo

dehli02:01:39

Ya, that makes sense. I think I’m running into issues on the cljs side though and not lumo at this point

dehli16:01:29

Hey all, I’m trying to use lumo to run some frontend tests, but it’s not finding my installed clojars (they are installed through boot). Is there an example out there of how this would look?

dehli16:01:13

would i need to create a pom file and then use maven to generate the class path for those files and then pass that to lumo?

dehli16:01:12

I see the -D flag which sounds like an easier path to go down. I think I’ll try sticking them in an edn file and then pulling them out from there

richiardiandrea16:01:32

@dehli if your deps are already in .m2 then multiple -D should work

dehli16:01:34

Ya, just trying to figure out how to store them so that boot and lumo could both use the same deps

dehli16:01:49

Also thanks! :slightly_smiling_face:

dehli16:01:17

Just found this issue which seems like a good option https://github.com/anmonteiro/lumo/issues/328 (using deps.edn)

richiardiandrea17:01:18

I also usually generate a file contained the resolved dependencies with boot with-cp...it's similar to what you see in that issue