Clojurians
#lumo
<
2017-06-21
>

This page is not created by, affiliated with, or supported by Slack Technologies, Inc.

hlolli13:06:53

using node's net works, I get data printed to stdout from lumo trough the tcp pipe. But I'm haveing diffuculty executeing code that I send via socket.write. As if there's no execute mechanism...

hlolli13:06:38

ahh! bingo, delimit with \n was what I was looking for, nice nice nice nice

honzabrecka14:06:04

@anmonteiro any plan on cutting new release?

anmonteiro15:06:11

@honzabrecka hrm I wanted to wait for the next CLJS release but happy to cut a release if you deem necessary

hlolli18:06:07

with lumo --help I see -K, --auto-cache Create and use .planck_cache should be .lumo_cache?

hlolli18:06:48

sooner or later my beer eyes would spot it

richiardiandrea18:06:18

lol nice catch :smile:

hlolli19:06:48

the topic of cutting a new release, I wouldn't protest to that. I tried running lumo on older versions, before the static linkings. Would save me 60mb on my repository not including the binary. But I can wait until next week if cljs will be released.

honzabrecka20:06:52

I can wait too :simple_smile:

moxaj20:06:29

@anmonteiro can't build master right now, is that expected?

anmonteiro20:06:52

not expected, what error are you getting?

anmonteiro20:06:58

CI is passing

moxaj20:06:43

...
Sifting output files...
Sifting output files...
Sifting output files...
Sifting output files...
Writing target dir(s)...
<...>\lumo\scripts\build.js:83
  );
  ^
SyntaxError: Unexpected token )
...

anmonteiro20:06:01

Node 7 can’t parse trailing commas at the end of function calls

moxaj20:06:06

@anmonteiro one down, two more popped up, build failed at second one:

Sifting output files...
Writing target dir(s)...
Building production bundle...
Error: Unexpected key 'pureExternalModules' found, expected one of: acorn, amd, banner, cache, context, dest, entry, exports, external, footer, format, globals, indent, interop, intro, legacy, moduleContext, moduleName, noConflict, onwarn, outro, paths, plugins, preferConst, sourceMap, sourceMapFile, targets, treeshake, useStrict, watch
----> bundle target/bundle.min.js
----> executing browserify via API
events.js:182
      throw er; // Unhandled 'error' event
      ^

Error: Cannot find module 'e:\Workspace\Clojure\lumo\target\bundle.min.js' from 'e:\Workspace\Clojure\lumo'

anmonteiro20:06:44

@moxaj run yarn install

moxaj21:06:17

@anmonteiro seems to be working now! Should this be mentioned in the readme? Or was this some special case?

anmonteiro21:06:28

I upgraded stuff recently

anmonteiro21:06:43

@moxaj you’re welcome to add the Node 8 requirement to the readme

moxaj22:06:35

I think this is the approach you hinted at

moxaj22:06:37

works in the repl

anmonteiro22:06:19

@moxaj looking good!

moxaj22:06:07

i'll do some more testing tomorrow and create the pr

anmonteiro22:06:15

sounds great