Clojurians
#lumo
<
2017-05-16
>

This page is not created by, affiliated with, or supported by Slack Technologies, Inc.

anmonteiro01:05:16

@hlolli merged your patch. are you on Linux or Mac?

anmonteiro01:05:43

you can download a Linux “nightly” here: https://s3.amazonaws.com/lumo-linux/lumo.zip

hlolli07:05:45

@anmonteiro Linux, nice to get the nightly build. At first glance didn't seem to have fixed it, but lumo prompts me this time with a segmentation fault message this time:

cljs.user=> (js/require "csound-api")
Segmentation fault (core dumped)
cljs.user=> (js/require "netlinkwrapper")
Segmentation fault (core dumped)

richiardiandrea15:05:51

@stbgz Really don't have time up my sleeves now for this, but I have discovered https://github.com/j4ts a (early days) JDK layer for transpiling from Java to JavaScript

anmonteiro15:05:38

@hlolli are you sure you’re running the new nightly?

anmonteiro15:05:42

it works for me on macOS

anmonteiro15:05:54

tested with a version pre and post fix

hlolli15:05:50

uhh... could be that I oversaw early this morning to remove the old binary before compying the new one with cp. I tray again

hlolli15:05:29

nope Im defenitly running this binary https://s3.amazonaws.com/lumo-linux/lumo.zip and still get these formentioned errors.

hlolli16:05:22

could it be that this isn't the nightly build behind it for linux?

anmonteiro16:05:26

hrm, it should be