Clojurians
#lumo
<
2017-04-21
>

This page is not created by, affiliated with, or supported by Slack Technologies, Inc.

darwin00:04:46

@anmonteiro thanks for your prompt fix! awesome work

anmonteiro00:04:32

I think I had thought about this before but never got around to it

anmonteiro00:04:51

this has the benefit of making Lumo work on other Linux distros

anmonteiro00:04:03

there was an issue about NixOS which fixed itself :slightly_smiling_face:

anmonteiro00:04:22

releasing 1.4.1

darwin00:04:12

yeah, this will solve a lot of messy issues with incompatible libs on users' machines, something you don’t want to be spending time on

darwin00:04:30

going to grab something to eat and will be back to test it hot from the press :slightly_smiling_face:

anmonteiro00:04:13

might be a while until CI ends

anmonteiro00:04:56

awaiting merge by the Homebrew team

dominicm05:04:43

@anmonteiro stdout fix out too then?

anmonteiro05:04:39

@dominicm let me know if you find any issues

grav07:04:52

Trying to use lein tach with lumo, and I get this error:

{:exit 1, :out "", :err "#error {:message Could not require org.bluebird in file promesa/impl.cljc, :data {:tag :cljs/analysis-error}, :cause #object[SyntaxError SyntaxError: Unexpected identifier]}\n"}

grav08:04:06

Seems lumo is not fond of promesa?

frankie08:04:14

Should the new "Require node modules from CLJS" https://anmonteiro.com/2017/03/requiring-node-js-modules-from-clojurescript-namespaces/ work in the new version of lumo? I get the error #error {:message "No such namespace: left-pad, could not locate left_pad.cljs, left_pad.cljc, or Closure namespace \"left-pad\""

frankie08:04:44

It seems it should, it's using cljs 1.9.521

pesterhazy12:04:00

Amazing that you made lumo work on nixos!

anmonteiro15:04:33

@frankie the feature is in closure compiler js, but not yet implemented in Lumo