Fork me on GitHub

I have a clojure version issue with a lein plugin, there is this jar on clojars called clojure-lsp-standalone, it has a org.clojure/clojure dep with 1.11.1 version, and there is lein-clojure-lsp plugin which just uses that jar. When I use the plugin in a clojure project that have other multiple plugins (but the deps of the project is using clojure 1.11.1), it doesn't find parse-long which is from 1.11.0 and it's being used by clojure-lsp, What's the best way to fix that?


I saw eval-in-project could be used, but not sure it's the best way


what's the best way to a plugin declare a clojure dep, AFAIK it should not have a org.clojure/clojure declared on its project.clj right?


From what I see in you do declare a vanilla 1.11 dep, right? Which sounds correct


I've had mixed experiences with dep resolution in plugins, at least two scars come to mind I've been happy coding e.g. Eastwood with up to (down to?) 1.7 compatibility, verified in CI, in practice it's little pain and a whole lot of peace of mind


you mean, it would be better if clojure-lsp had clojure as a older version to better compatibility?


I see, I thought plugins could override that, but makes sense