Fork me on GitHub
#emacs
<
2017-01-07
>
madstap21:01:09

Hi, starting earlier today, when I start emacs I get a buffer with:

Warning (emacs): Unable to activate package `flycheck'.
Required package `let-alist-1.0.4' is unavailable
Warning (emacs): Unable to activate package `flycheck'.
Required package `let-alist-1.0.4' is unavailable
Warning (emacs): Unable to activate package `flycheck'.
Required package `let-alist-1.0.4' is unavailable
Does anyone know what this might be caused by? I have an almost totally vanilla prelude installation on emacs 24.5.1

dpsutton21:01:42

can you list packages?

dpsutton21:01:50

M-x list-packages

dpsutton21:01:57

and youre looking for let-alist

madstap21:01:34

Yeah, I can find it

madstap21:01:56

It says available, just like your screenshot

dpsutton21:01:59

can you install it?

dpsutton21:01:05

and then restart emacs

dpsutton21:01:17

it looks like it goes from a package to inside emacs with 25

dpsutton21:01:28

wondering if maybe there's a bug in loading dependencies

madstap21:01:42

the weird thing is that it worked this morning...

madstap21:01:54

I can't install it

madstap21:01:33

The relevant part of *messages* (maybe)

Contacting host: 
Type "q" to delete help window, M-x scroll-up to scroll help.
Install package `let-alist-1.0.4'? y
Contacting host:  [2 times]
File mode specification error: (void-function flycheck-mode)
Making version-control local to let-alist-autoloads.el while let-bound!
run-hooks: Symbol's function definition is void: flycheck-mode
Install package `let-alist-1.0.4'? y
Contacting host:  [2 times]
run-hooks: Symbol's function definition is void: flycheck-mode

dpsutton21:01:07

it almost sounds like a hobbled version of flycheck-mode is running without a dependency and just ruining everything

dpsutton21:01:15

can you disable flycheck mode and then try again?

dpsutton21:01:21

set flycheck globally off

madstap21:01:27

How do I disable flycheck?

dpsutton21:01:29

(global-flycheck-mode nil)

madstap21:01:40

I get: Debugger entered--Lisp error: (void-function global-flycheck-mode)

dpsutton21:01:00

i think you've got a half state of something

dpsutton21:01:12

nuke flycheck out of your elpa dir and try installing again?

madstap21:01:48

That worked!

madstap21:01:22

So, basically, the old "turn it off and turn it back on"

dpsutton21:01:39

there may have been an error loading or downloading a dependency

dpsutton21:01:51

but it tried to struggle on in its malformed state

dpsutton21:01:06

and happily threw errors in that message buffer as it tried and prevented everything from working haha

madstap21:01:53

Yeah, it worked for the most part, except for the paren stuff like paredit and rainbow delimiters

chris_johnson23:01:27

Emacs newbie moment: I finally bothered to learn dired a little bit. It’s bliiiiiiiissss