Fork me on GitHub
#datomic
<
2015-11-05
>
bhagany00:11:45

@grounded_sage: best of luck on your decision. I agree, it doesn't sound easy.

pesterhazy09:11:14

Is it absolutely necessary/required/recommended to keep peer libraries and Transactor versions in sync?

pesterhazy09:11:57

In particular, can I backup my db using a more recent version of Datomic Pro?

robert-stuttaford11:11:48

i think it’s ok as long as both sides are on the same side of a breaking change

stuartsierra13:11:40

@pesterhazy: In general, peer and transactor do not need to be at exactly the same version. The release notices make it clear for which releases they do have to be in sync.

pesterhazy13:11:47

so basically as long as both versions are more recent than 0.8.3705, it should be okay

stuartsierra13:11:18

Obviously, it is recommended to keep both versions up to date, for bugfixes.

pesterhazy13:11:50

right. it looks like the last few versions were mostly bugfixes anyway

pesterhazy13:11:56

very helpful, thanks