Fork me on GitHub
#cursive
<
2021-03-28
>
j00:03:02

Is it possible to use clojure 1.10 with cursive? I noticed that we can only download up to clojure version 1.9:

cfleming00:03:01

Oh, I haven’t updated that - I’ll fix that. Yes, you can, I’d recommend using the Clojure Deps project type, which will allow you to manage your dependencies.

👍 2
cfleming00:03:17

That will come with Clojure 1.10.x by default.

j00:03:20

How do I switch to Clojure Deps project type?

cfleming00:03:32

You can either create a new project and select that option in the wizard, or you can create a deps.edn file in the root of your project containing {} and then right click it in the project view and “Add as Clojure Deps project”.

j00:03:51

I added deps.edn and it works perfectly! Thanks again! 🙂

👍 1
Azzurite11:03:36

Using deps.edn also lets other devs not using intellij+cursive work with your project 🙂

👍 2