Fork me on GitHub
#cursive
<
2020-07-24
>
maxt09:07:27

We have also experienced problems with commiting clojure-deps.xml. Mainly related to developers running different versions of idea and cursive and the contents jumps around, causing cursive to not detect it as a deps project any more.

1
Paul Newberry10:07:08

Hi, I'm trying to get Cursive working on Windows but I'm having a few problems. I've installed Clojure on Windows via the recommended way (as mentioned on the Cognitect website) and it is available via powershell. When trying to use this in Cursive however, it keeps defaulting to running in CMD. I've set the terminal path to be powershell.exe. I also get the error could not create shim Does anyone know how to get this working? Any help would be much appreciated!

💭 1
1
cfleming23:07:35

Cursive doesn’t support running via the command line on Windows yet. Here’s the recommended approach: https://cursive-ide.com/userguide/deps.html#windows

cap10morgan17:07:52

I'm getting the error Could not create shim in tools-deps projects after updating clojure to 1.10.1.561 and Idea to 2020.1.4. On both macOS 10.15.6 and Big Sur dev beta 3. Anyone else seeing that?

onetom17:07:32

I have the same set of versions, but I haven't seen any error like that. Where is that error appearing? Are you using the Use CLI tools (recommended) option?

cap10morgan19:07:54

It's a popup when I open the project. Where is that option?

cfleming22:07:52

@U06FS3DLH Could you email me your log file from Help | Show log in Finder? <mailto:[email protected]|[email protected]>. I’ll try to look at that over the weekend, someone else reported this yesterday too.

onetom15:07:40

I just got this shim error on macOS. I switched to the Use tools.deps directly option yesterday and I'm on version 0.9.745 IntelliJ IDEA 2020.1.4 (Ultimate Edition) Build #IU-201.8743.12, built on July 21, 2020 Licensed to Tamas Herman Subscription is active until November 27, 2020 Runtime version: 11.0.7+10-b765.65 x86_64 VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o. macOS 10.15.6 GC: ParNew, ConcurrentMarkSweep Memory: 4029M Cores: 8 Registry: suppress.focus.stealing.active.window.checks=true, suppress.focus.stealing.disable.auto.request.focus=true Non-Bundled Plugins: AceJump, IdeaVIM, Org4Idea, PlantUML integration, TabSwitch, com.4lex4.intellij.solarized, com.alayouni.ansiHighlight, com.github.pshirshov.bytecodeeditor, zielu.gittoolbox, com.intellij.ideolog, com.intellij.plugins.watcher, com.paperetto.dash, com.vincentp.gruvbox-theme, de.netnexus.camelcaseplugin, de.thomasrosenau.diffplugin, io.protostuff.protostuff-jetbrains-plugin, name.kropp.intellij.makefile, net.vektah.codeglance, nix-idea, org.intellij.RegexpTester, org.jetbrains.plugins.localization, org.jetbrains.plugins.rest, com.dmarcotte.handlebars, com.cursiveclojure.cursive, Pythonid, ru.meanmail.plugin.requirements, com.intellij.plugins.html.instantEditing, com.jetbrains.plugins.jade, intellij.prettierJS, org.asciidoctor.intellij.asciidoc, org.plugin.dot.id, org.toml.lang, org.rust.lang

cap10morgan15:07:28

@U0567Q30W Just emailed my log file

onetom15:07:58

Then I switched back to Use CLI tools with this version: /nix/store/q45vy8nvlfvz528hm1bp5fl6phy9gpi6-clojure-1.10.1.510/bin/clojure and now I can start a REPL without triggering that shim error