Fork me on GitHub
#clojurescript
<
2017-09-18
>
tony.kay02:09:22

@petterik Did you ever get your build running faster with npm-deps?

tony.kay02:09:41

I’m seeing a 4x or more slowdown of cljsbuild (via lein cljsbuild)

tony.kay02:09:42

I’m aware of the open issue CLJS-2339

tony.kay02:09:47

Hm. I take that back. Something else must be going on.

tony.kay03:09:49

I’ve put my findings in that Jira ticket.

tstephens04:09:14

I'm trying to use :npm-deps with a library called "vexflow", but when I require it, all I get back is an empty object. It seems the package.json refers to a source file bundled with webpack; is this a common problem?

anmonteiro04:09:32

@tstephens might be an issue until this is solved: https://github.com/google/closure-compiler/pull/2597

tstephens04:09:16

thanks; in the interim, do I just need to pull it in the "old fashioned" way, then?

anmonteiro05:09:58

add a :foreign-libs entry

grumplet12:09:01

I’m wondering whether anyone here has experience of using antizer?

harrytuttle17:09:35

In the clojurescript docs, there's a retracted printf and elsewhere there's suggestions to use goog.string from gcl. Is that still the recommended way to go? Trying to simplify this sort of code in hiccup: (str "translate(" cell-size " " cell-size ")")

darwin17:09:27

@burnsidemk why don't you wrap it in your own function?

anmonteiro17:09:29

@burnsidemk my personal choice is to use goog.string.format

harrytuttle17:09:04

@anmonteiro that's a cool resource! I've been struggling a bit with using gcl from clojure

ingared20:09:54

@channel: isMounted is deprecated. Instead, make sure to clean up subscriptions and pending requests in componentWillUnmount to prevent memory leaks. I’m getting the following warnings in my front end application. Any suggestions to eliminate this ? I’m using rum with mixins to query.

levitanong20:09:55

@ingared where are you using isMounted? And what are you using it for?

ingared20:09:23

I’m not using isMounted but I’m using a react-mixin with (init , did-mount, will-update, will-unMount) .

levitanong20:09:14

Is this mixin something you wrote or a library?

ingared21:09:07

I have written it .

ingared21:09:37

I didn’t get those exceptions for a while. Started appearing recently though.

amonks21:09:30

did you upgrade your react version?

ingared21:09:13

No but I started using react-material-UI Components and added [cljsjs/react “15.6.1-1”] [cljsjs/react-dom “15.6.1-1"] [cljs-http “0.1.43”]

ingared21:09:43

[cljs-react-material-ui “0.2.48”]

ingared21:09:10

This is one of my recent changes and my guess is that react 15.6.1-1 is throwing this warnings. Rum on the other hand is using a 15.4.20

ingared21:09:06

@amonks: Thanks for the tip. Figured out this is beacuse of some of the react-material-UI components

ingared21:09:32

which are using react 15.6.1-1.

ingared21:09:38

Removing [cljsjs/react “15.6.1-1”] & [cljsjs/react “15.6.1-1"] solved my problem.

ingared21:09:59

This is a suggestion from https://github.com/madvas/cljs-react-material-ui . Don’t understand why one need to add (react and react-dom) to the dependencies ?