Fork me on GitHub
#clojure-uk
<
2019-08-08
>
practicalli-john07:08:03

I hit the £1,000 mark for my charity ride from Lands End to John O’Groats, so thanks to all who have contributed so far. I will be climbing 48,000 feet (higher than Mount Everest 29,000 ft) and covering 1,000 miles (16,000km) over the course of 9 days and sleeping in a tent each night. It’s going to be a real test of my motivation and a big strain on my unhealthy body. Wish me luck. https://uk.virginmoneygiving.com/jr0cket

practicalli-john14:08:58

its quiet in here today.... tumbleweed tumbleweed tumbleweed tumbleweed tumbleweed tumbleweed tumbleweed tumbleweed tumbleweed tumbleweed tumbleweed tumbleweed tumbleweed tumbleweed

otfrom16:08:47

how about a clojure question...

otfrom16:08:55

I've got a deps.edn like this:

{:paths ["resources" "src"]
 :deps {org.clojure/clojure  {:mvn/version "RELEASE"}
        org.clojure/data.csv {:mvn/version "0.1.4"}
        net.cgrand/xforms    {:mvn/version "0.18.2"}
        witan.send           {:local/root "../witan.send"
                              :deps/manifest :pom}
        witan.send.driver    {:local/root "../witan.send.driver"
                              :deps/manifest :pom}}
 :aliases
 {:test {:extra-paths ["test"]
         :extra-deps {org.clojure/test.check {:mvn/version "RELEASE"}}}
  :runner
  {:extra-deps {com.cognitect/test-runner
                {:git/url ""
                 :sha "76568540e7f40268ad2b646110f237a60295fa3c"}}
   :main-opts ["-m" "cognitect.test-runner"
               "-d" "test"]}}}

otfrom16:08:25

and I'm getting Compiler Exceptions caused by this:

1. Caused by java.io.FileNotFoundException
   Could not locate witan/send/driver/ingest__init.class,
   witan/send/driver/ingest.clj or witan/send/driver/ingest.cljc on
   classpath.

otfrom16:08:49

clj -Stree looks sensible to me (it is reading the pom.xml files on my local/root trees, but doesn't seem to be finding the code under src in those directories

otfrom16:08:59

any idea what I'm doing wrong or where I should look next?

otfrom16:08:10

- A deps.edn n00b

otfrom16:08:58

upgrading clj to the latest seems to have helped (I'm at least breaking in a new place now)

otfrom16:08:10

and I feel I can fix that

seancorfield16:08:00

@otfrom Yeah, I think local deps were really only supported for deps, not pom, until a more recent version of tools.deps.