Fork me on GitHub
#cljsjs
<
2017-01-27
>
pupeno11:01:19

Another noob question...Writing react-toolbox-1.3.3-0.jar… where is it?

pupeno12:01:08

Can anybody give me a hand figuring out externs for an ES6 library?

peeja17:01:31

Is there a way to use Bootstrap's Less via cljsjs?

juhoteperi17:01:44

@peeja No, Cljsjs package only includes the JS files

peeja17:01:05

Is there a way to get them without resorting to Bower?

juhoteperi17:01:30

@peeja However, you can include Webjars for package with all the files: [org.webjars.bower/bootstrap "3.3.7"]

juhoteperi17:01:25

That jar includes e.g. META-INF/resources/webjars/bootstrap/3.3.7/less/bootstrap.less

peeja17:01:32

Ah, sweet! Thanks.

juhoteperi17:01:56

my Less4clj package can directly import files from classpath and has special case for resolving imports from webjars: https://github.com/Deraen/less4clj

peeja17:01:17

Dang, that's fantastic!

pupeno23:01:00

I’m trying to package react-toolbox (https://github.com/pupeno/packages/commit/a054c1cdeb0a1b4195e974113826f17f0a4f5f72) and when I load it in my app, I get the error: Uncaught Error: locals[0] does not appear to be a module object with Hot Module replacement API enabled. You should disable react-transform-hmr in production by using env section in Babel configuration. See the example in README: https://github.com/gaearon/react-transform-hmr

pupeno23:01:13

Does that ring a bell to anybody?