Clojurians
#cljs-dev
<
2017-04-14
>

This page is not created by, affiliated with, or supported by Slack Technologies, Inc.

lauri05:04:33

I failed to compile my project after upgrading ClojureScript dependency from version 1.9.456 to 1.9.518 - here is a minimal reproduction and explanation about why it fails: https://github.com/laurio/cljs-1973-issue @dnolen should i create a jira ticket about this issue?

dnolen13:04:06

@lauri yes please

dnolen13:04:35

I looks like expand-libs probably doesn’t do quite the right thing

dnolen13:04:28

hrm actually no, expand-libs is fine

dnolen13:04:36

@lauri actually I believe I’ve fixed this in master

dnolen13:04:01

@anmonteiro would be nice to test master when you get a chance - this is a pretty bad regression so I would like to push out a release today

anmonteiro14:04:07

@dnolen haven't tried yet because I'm on phone, but I think you can just remove distinct-by entirely

anmonteiro14:04:26

Because module-deps won't return duplicate stuff

anmonteiro15:04:00

The point of distinct-by was to dedup between user-provided and indexed modules

anmonteiro15:04:23

Which may not be a big deal, and seems to be causing more trouble than it's worth

anmonteiro15:04:38

I'll let you know more once I'm at the computer

dnolen15:04:56

@anmonteiro cool thanks!

anmonteiro16:04:41

@dnolen OK looked at your fix and looks good. everything works after testing

anmonteiro16:04:54

should be good to go after applying that patch

anmonteiro16:04:13

@lauri thanks for bringing this up and for the repro!

lauri17:04:29

@anmonteiro @dnolen thank you for a quick fix!