Fork me on GitHub
#clj-kondo
<
2021-06-05
>
Helins12:06:49

There must be something obvious I can't see. I can't get to import the config of a lib I've written. I know it is on the classpath, I see it in the lib jar under "clj-kondo.exports/io.helins/mprop/config.edn". I run the same import command as in the doc. I know this jar is present since I can see it is being linted. Something wrong with the path?

borkdude12:06:58

@adam678 How did you "import" the config? clj-kondo --lint $(clojure -Spath) --dependencies ?

Helins12:06:50

clj-kondo --copy-configs --dependencies --lint "$(clojure -Spath)"
Yes, copy/pasted this line from https://github.com/clj-kondo/clj-kondo/blob/master/doc/config.md

borkdude12:06:12

oh right, and you didn't see the output similar to "copied config to ..." ?

borkdude12:06:43

do you have a local .clj-kondo directory?

Helins12:06:43

No, and indeed nothing is copied to ./.clj-kondo 😞

borkdude12:06:05

is this library public? I can try it myself

borkdude12:06:59

(be back later)

Helins12:06:09

Almost public

borkdude12:06:34

is it a git dep or jar dep

Helins12:06:23

I've installed it locally (so jar dep)

Helins14:06:08

Actually I am doing something wrong at import. I can't reproduce the clj-kondo/config example. Weird... I never had this problem. It's in my deps, on my classpath, and I have a .clj-kondo directory with proper R/W access...

Helins14:06:41

All I get is a long list of errors + warnings from and it ends like this without any copying done:

linting took 2750ms, errors: 132, warnings: 433

Helins14:06:25

Okay, I feel ashamed. All this fuzz has been solved... by an update of Clj-kondo. I still have no idea what went wrong though.

borkdude14:06:01

no need to be ashamed, glad it's solved

Helins14:06:19

Always makes me think of IT Crowd's "Did you try turning it off and on again..." when something like that happens. Anyways, have a nice WE!