Fork me on GitHub
#cider
<
2015-07-03
>
voxdolo15:07:54

not-strictly-cider-question-about-projectile: any idea why toggle-between-implementation-and-test will let me go from a clojure ns to it's test, but not vice-versa?

voxdolo16:07:02

when I try to toggle back to the implementation from the test, I get "No matching test file found"

voxdolo16:07:01

I'd previously assumed that this was caused by having my clojure source at a nonstandard location, but that's no longer the case.

voxdolo16:07:09

alternatively: is there a better place to ask?

voxdolo16:07:08

eh, found the projectile gitter. I'll ask there. sorry for the line noise 😄

bozhidar18:07:02

@voxdolo: it’s not like I don’t maintain both projects 😉

voxdolo18:07:27

@bozhidar: yeah, that's why I started here :) moving my question was all about trying to keep it on-topic ;)

jrychter18:07:54

@bozhidar: I wanted to thank you for the fantastic work you are doing on Cider. We don't thank people or praise people often enough. I use your code every day to develop systems and it makes my life better!

seancorfield19:07:43

Emacs Live updated its dev packs to use CIDER 0.9.1 and I updated our project to cider-nrepl 0.9.1 but get a warning about clj-refactor being outdated when I start a REPL — is that likely to be an issue in Emacs Live’s dependencies or something else?

seancorfield19:07:45

; CIDER 0.9.1 (Java 1.8.0_31, Clojure 1.7.0, nREPL 0.2.10)
WARNING: The following nREPL ops are not supported:
extract-definition rename-file-or-dir stubs-for-interface warm-ast-cache
Please, install (or update) refactor-nrepl and restart REPL.
You can mute this warning by changing cljr-suppress-middleware-warnings.
WARNING: clj-refactor and refactor-nrepl are out of sync.
Their versions are 1.1.0-SNAPSHOT and 1.0.5, respectively.
You can mute this warning by changing cljr-suppress-middleware-warnings.
user>

seancorfield20:07:17

Hmm, no, that’s pretty recent… That’s @benedek’s commit from July 2nd.

malabarba20:07:16

@seancorfield your clj-refactor is up to date. It's the clojure side (refactor nrepl) that's behind

malabarba20:07:46

Bump it to 1.1.0-SNAPSHOT

seancorfield20:07:16

Then the message is extremely confusing (or just downright incorrect).

seancorfield20:07:50

WARNING: clj-refactor and refactor-nrepl are out of sync.
Their versions are 1.1.0-SNAPSHOT and 1.0.5, respectively.

seancorfield20:07:26

Those versions are the wrong way round if refactor-nrepl is meant to be 1.1.0-SNAPSHOT. I’ll update my project and confirm the warning goes away.

malabarba20:07:21

No, the message is saying that your refactor-nrepl is currently on 1.0.5.

malabarba20:07:39

It's not saying what it should be.

seancorfield20:07:34

If you mention two things and then mention two things "respectively", that means the second two things apply in order to the first two things.

seancorfield20:07:51

That’s what "respectively" means in English simple_smile

seancorfield20:07:44

So it indicates you need to somehow set those two libraries to match those versions.

seancorfield20:07:54

I think I’ve complained about this poor wording before.

seancorfield20:07:27

It would be much clearer if it stated a "call to action" rather than just what it thinks is wrong.

seancorfield20:07:30

Just adding a line saying "Either change clj-refactor to 1.0.5, or change refactor-nrepl to 1.1.0-SNAPSHOT." would make a big difference.

malabarba20:07:39

Ah yes. We are agreed on the respectively. I think the confusion was in the overall meaning

seancorfield20:07:47

I will confirm that updating refactor-nrepl to 1.1.0-SNAPSHOT makes the warning go away… however, I do not want a snapshot in my project dependencies… Any ETA on a stable 1.1.0 release?

malabarba20:07:06

No idea, I'm just a user

malabarba20:07:20

You can ask them on gitter

seancorfield20:07:41

Fair enough. Thank you.

malabarba20:07:48

Or you could ask emacs live to not depend on a snapshot too :-)

seancorfield20:07:02

Heh, good point simple_smile

bozhidar22:07:05

@benedek ^^

bozhidar22:07:20

more arguments in favour of less deps simple_smile

bozhidar22:07:26

(for end users)

bhagany23:07:10

fwiw, I don't see what's wrong with that error message