Fork me on GitHub
#chlorine
<
2020-10-06
>
flyingpython23:10:18

Hi @seancorfield I just ran scoop update on my files and Clojure got updated but now when I run the clj commandline with your old deps.edn file it spits out some messages saying some things are deprecated. So I downloaded your latest deps.edn which doesn't spit out the deprecated messages but I can't get REBL to run with it. It says regarding your socket-rebl option that it assumes REBL is on your classpath - so how do I set it up like this so it will run? Also do I need to run both :rebl and :socket-rebl options on the clj? And this is working on Windows and other platforms now, so no need to have the platform-specific options like :rebl-11-win? Before there was just a line in your old deps.edn to point to the folder where REBL was located which was how I was running it.

flyingpython23:10:02

Also I noticed that downloading REBL now from Cognitect it seems to come in a folder with datomic dev tools and an install script but it only has instructions to install from Bash. Maybe this install script puts REBL on the classpath? If so, how do I run the install script from Powershell in Windows if possible?

seancorfield23:10:04

The dev-tools includes the updated JARs for both Datomic and REBL. The install script just runs mvn as I recall so you could run the REBL line directly on Powershell if you have Maven installed, or you could use deps-deploy to install it (via the alias in the dot-clojure file I think).