Fork me on GitHub
#braid-chat
<
2016-03-22
>
grounded_sage13:03:08

Just working on getting Braid up and running. Does someone know what this means? No implementation of method: :make-reader of protocol: #' found for class: nil happens after I run lein run -m clojure.main script/figwheel.clj when following these up and running instructions https://github.com/braidchat/braid/blob/master/developing.md

grounded_sage13:03:20

Actually happening straight after I start the server now (chat.server.handler/start-server! 5555)

rafd15:03:09

@grounded_sage: run lein -v ... i suspect either your lein or your java are old

rafd15:03:39

lein should be > 2.0.0, and java should be 1.8.x

rafd15:03:58

if that fixes it for you, add a note to the docs and PR simple_smile

sveri17:03:44

@grounded_sage: @rafd Hey, I just tried to setup braid too and run into the same error. I have leiningen 2.6.1 and JDK 1.8.0_74 installed

sveri18:03:41

Turns out, you have to run figwheel and lesscss first.

sveri18:03:40

The error occurs cause the it misses some css and js files and crashes on it.

sveri18:03:51

I added a PR for the minor stuff I found

rafd18:03:49

@sveri: thanks!

grounded_sage23:03:04

Awesome. Had a feeling it may be that but thought it was just a human error.