Fork me on GitHub
#boot
<
2019-01-24
>
alexyakushev10:01:22

Sorry, how can boot-bin become deprecated while boot-native supports neither MacOS nor Windows? Perhaps, deprecated wording is too strong?

borkdude11:01:18

@alexyakushev where do you read deprecated?

borkdude11:01:31

yeah, that’s strange. it doesn’t instill confidence in the stability of boot

flyboarder14:01:51

@alexyakushev @borkdude the boot-native loader does indeed work on windows and macos, the documentation needs to be updated. For v3 boot-native is an in-place replacement for boot-bin, for v4 we are working on native image support which is only available for Linux today. Everything will be updated accordingly this week.

flyboarder14:01:31

Also boot-native will probably get renamed to loader or bootstraps or something like that - the current naming is poor

flyboarder14:01:38

The important thing to note is that V3 will maintain backwards compatibility with the current V2 implementation. Everything will continue to work as it does today.

dave14:01:43

sounds amazing!

dave14:01:23

so once boot 3.0 is out, if i run boot -u, everything should just work™ without me needing to change or install anything?

flyboarder16:01:33

@dave almost, since we are replacing the loader you will need to update boot via package manager, boot-bin currently blocks versions higher than 2.X

flyboarder16:01:13

The new loader is version agnostic and should actually work with a V2 project although it’s not supported

dave17:01:37

cool! fair enough 🙂

flyboarder19:01:40

https://github.com/boot-clj/bootstrap ^ I renamed it for now, more updates and a blog post still to come 🙂