Fork me on GitHub
#beginners
<
2016-05-08
>
herrvogel20:05:42

Is there an easy way to apply a function to its result n times?

nathansmutz21:05:12

Gonna give emacs install another whack today. Last episode: * Spacemacs complained of something missing * Decided to try latest emacs: PPA's exist for out-of-date and bleeding-edge-alpha; nothing for latest-stable *Downloaded and built with Make: Failed missing multiple libraries not available via apt. * A yak moos softly in the distance...

adamkowalski22:05:56

whats the best way to do matrix multiplication quickly in clojurescript? should I use transients? can I write that specific code in an iterative way somehow?

nathansmutz22:05:36

Seemed to get Emacs 24.5 installed on Mint with the script on this page: https://github.com/favadi/build-emacs . Now Spacemacs can't seem to download stuff.

tom22:05:42

what is spacemacs saying?

nathansmutz22:05:35

Warning (spacemacs): Error connection time out for melpa repository! Warning (spacemacs): Error connection time out for org repository! Warning (spacemacs): An error occurred while retrieving the theme, using default theme. (error: (error Package `spacemacs-theme-' is unavailable)) Warning (initialization): An error occurred while loading `/home/nathan/.emacs.d/init.el': error: Package `evil-' is unavailable To ensure normal operation, you should investigate and remove the cause of the error in your initialization file. Start Emacs with the `--debug-init' option to view a complete error backtrace.

tom22:05:00

start with --debug-init

nathansmutz22:05:48

Seems to be working now, so far. (Besides some error about converting fonts on the command line) Just installed evil, bind-map, bind-key

tom22:05:36

Quick question, have you tried out prelude before?

tom22:05:10

I run emacs 24.5 on Windows 10 and on Archlinux. Used Prelude to get emacs set up, got cider with it and all. Easier that chasing down packages anyway.

tom23:05:28

I'm thinking a lot of (most?) people in the #C099W16KZ channel use it

nathansmutz23:05:16

Looks like trouble is stemming from the melpa repository. As spacemacs continues installing, I'm seeing bad file messages and such

nathansmutz23:05:47

I'll look into the prelude route.

nathansmutz23:05:34

It might be flaky internet on my side

tom23:05:51

Prelude's installation steps might go smoother for you. On windows 10 I ran into a problem getting packages from melpa; windows 10 didn't allow https for melpa and so the connection would fail. With just http it'll work though.

nathansmutz23:05:09

I'm working with Linux Mint (Ubuntu offshoot). I suppose that the similar solution would be: emacs --insecure That wasn't working for spacemacs so far.

bwstearns23:05:04

I'm trying to use localrepo for the dependencies for the clj-drone library and I can't get localrepo to work. My ~/.lein/.profiles.clj is below but when I run lein localrepo install h264/h264-decoder-1.0.jar h264-decoder/h264-decoder 1.0 I get 'localrepo' is not a task. See 'lein help'.

{:brian {:dependencies [[clj-time "0.11.0"]
                       [org.clojure/tools.namespace "0.2.11"]
                       [funcool/cuerdas "0.7.1"]]
        :injections []
         :plugins [[lein-localrepo "0.5.3"]
                   [lein-ancient "0.5.5"]
                   [jonase/eastwood "0.2.1"]
                   [lein-kibit "0.0.8"]
		   [cider/cider-nrepl "0.12.0"]
                   [lein-pprint "1.1.2"]]
        :test-refresh {:notify-command ["terminal-notifier" "-title" "Tests" "-message"]}}}

bwstearns23:05:23

Am I missing a step where I select a profile or run global deps or something?

nathansmutz23:05:10

If this is a down-repository or bad-bandwidth problem, is there something I can do to get the failed files to install later, or do I need to just nuke ~/emacs.d, and .spacemacs and start over?

tom23:05:23

If I were you I'd nuke and start over and try to get emacs 24.5 built. Then install Prelude on top of that. Try switching to http and see if that helps network issues.

nathansmutz23:05:47

What's the command for switching to http?

nathansmutz23:05:31

The current Linux situation is that prelude requires 24.4 and suggests 24.5, and punts to the Emacs wiki for install instructions, which punts to apt-get which installs 24.3. I figured out how to get the source repositories going on Mint for the emacs24 build-deps. I'll try the Make route again to see if there was some hidden requirement that didn't get pulled down by the script i used.