Fork me on GitHub
#babashka
<
2024-07-11
>
markx00:07:11

Hi, does babashka.deps/add-deps work on jvm? I'm trying to write a bb script but use jvm for dev, but I couldn't get it to work.

(require
  '[babashka.deps :as deps])
(deps/add-deps '{:deps {honeysql/honeysql {:mvn/version "1.0.444"}}})
I got No such var: deps/add-deps

borkdude06:07:02

It doesn’t but in Clojure 1.12 there is a similar API called add-lib

borkdude07:07:04

I guess for the JVM I could try to write a compatibility layer (using the Clojure 1.12 stuff)

markx23:07:41

So it's a known issue then. Thanks. I'll have to stay with bb for dev then.