Fork me on GitHub
#aws
<
2019-06-18
>
bmaddy02:06:08

I'm trying to give aws-api a try and can't seem to get anywhere. Does anyone have any idea how to start debugging this error? I do have a [default] section in my ~/.aws/credentials file and it doesn't appear to be a credentials issue.

a.stavonin02:06:54

do you have all required dependencies like com.cognitect.aws/endpoints and com.cognitect.aws/s3?

bmaddy02:06:01

Oh, and my deps are:

:deps {org.clojure/clojure {:mvn/version "RELEASE"}
        metasoarous/oz {:mvn/version "1.6.0-alpha3"}
        com.cognitect.aws/api {:mvn/version "0.8.305"}
        com.cognitect.aws/endpoints {:mvn/version "1.1.11.568"}
        com.cognitect.aws/s3 {:mvn/version "722.2.468.0"}}

ghadi03:06:27

@bmaddy oz is pulling down 90000000 dependencies, almost certainly jetty is in conflict

bmaddy03:06:39

Ah, ok. I'll look into how to that tomorrow. Thanks @ghadi--I appreciate it!

ghadi03:06:05

add com.cognitect/http-client "0.1.99" top-level

a.stavonin03:06:06

@bmaddy what is your JVM version? I had issues with cognitect.aws for JVM > 8

bmaddy03:06:58

;; Clojure 1.10.1, Java 1.8.0_192

ghadi03:06:22

that's not it @s-a-n-9.

ghadi03:06:23

{:deps {org.clojure/clojure {:mvn/version "1.10.1"}
        metasoarous/oz {:mvn/version "1.6.0-alpha3"}
        com.cognitect.aws/api {:mvn/version "0.8.305"}
        com.cognitect.aws/endpoints {:mvn/version "1.1.11.568"}
        com.cognitect/http-client {:mvn/version "0.1.99"}
        com.cognitect.aws/s3 {:mvn/version "722.2.468.0"}}}

ghadi03:06:25

should get you going.

bmaddy03:06:39

Indeed it does--thank you!