Fork me on GitHub
#announcements
<
2020-01-17
>
alexmiller03:01:34

tools.deps.alpha 0.8.264 and clj 1.10.1.496 are now available.

alexmiller03:01:38

The main change in this is that support for s3 maven repos has been completely replaced and is now using a new impl of the Maven resolver transporter API based on the cognitect aws-api. The old version used the transporter-wagon adapter, the unmaintained spring s3 wagon, and the AWS Java SDK. Those deps have been happily dropped on the floor, and all other deps were bumped as well. Support for some newer AWS credential sources may be better, particularly when running on AWS. Also, you can explicitly set the s3 bucket region in your deps.edn like {:mvn/repos {"my-bucket-repo" {:url ""}}} - this is a feature of this transporter, not a general AWS thing.

niwinz19:01:00

Hmm, After update im getting a strange exception

Downloading: com/cognitect/transit-clj/0.8.319/transit-clj-0.8.319.pom from 
Error building classpath. org.apache.maven.repository.internal.DefaultModelResolver.<init>(org.eclipse.aether.RepositorySystemSession, org.eclipse.aether.RequestTrace, java.lang.String, org.eclipse.aether.impl.ArtifactResolver, org.eclipse.aether.impl.VersionRangeResolver, org.eclipse.aether.impl.RemoteRepositoryManager, java.util.List)
java.lang.NoSuchMethodException: org.apache.maven.repository.internal.DefaultModelResolver.<init>(org.eclipse.aether.RepositorySystemSession, org.eclipse.aether.RequestTrace, java.lang.String, org.eclipse.aether.impl.ArtifactResolver, org.eclipse.aether.impl.VersionRangeResolver, org.eclipse.aether.impl.RemoteRepositoryManager, java.util.List)
        at java.base/java.lang.Class.getConstructor0(Class.java:3349)
        at java.base/java.lang.Class.getConstructor(Class.java:2151)
        at clojure.tools.deps.alpha.extensions.pom$model_resolver.invokeStatic(pom.clj:49)
[...]

alexmiller19:01:35

What are your full deps? And do they include pomegranate?

niwinz19:01:29

hmm not explicitly

niwinz19:01:59

with 1.10.1.492 works ok...

niwinz19:01:52

it fails always after com/cognitect/transit-clj/0.8.319/transit-clj-0.8.319.pom i dont know if is something relevant

alexmiller19:01:56

Happy to help diagnose but you’re going to have to give me more context to repro

niwinz19:01:24

at this momment i don't have more context, maybe tomorrow i try to investigate more. If i found something "relevant" i ping you

niwinz19:01:50

ok is something related to :local/root

niwinz19:01:14

i commented that dependencies and the -Stree is now can resolve all deps..

niwinz19:01:19

the simplest reproducible case is (deps.edn):

{:deps {somepackage {:local/root "path/to/package" 
:deps/manifest :pom}}}

alexmiller19:01:36

thx, repro'ed. I'll take a look

alexmiller19:01:59

must be some drift in the pom model reading code across lib versions

alexmiller21:01:52

fixed, but might be a couple days before I can release on brew (they gets antsy if you release too frequently)

alexmiller21:01:09

should downgrade for the moment to 492

niwinz00:01:53

thanks! no problem i stay with 492 for the moment

alexmiller21:01:14

new release 1.10.1.502 is now available and fixes this issue